collapse

* Links de Robótica

* Posts Recentes

Printer 3D barata por andre_f_carvalho
[Hoje às 13:09]


Procuro resistências 220 Ohm de 1% por brunus
[02 de Dezembro de 2016, 15:50]


Package de cond 10uF 35V smd? por KammutierSpule
[02 de Dezembro de 2016, 11:19]


Videos hipnoticos de mecanica industrial por TigPT
[02 de Dezembro de 2016, 00:07]


FPV Drone Racing? por brunus
[02 de Dezembro de 2016, 00:00]


Decodificar cabo por Hugu
[01 de Dezembro de 2016, 23:11]


Ajuda para replicar e reparar um Dimmer por brunus
[30 de Novembro de 2016, 23:23]


Adaptar impressora 3D a Drill Maschine por Hugu
[30 de Novembro de 2016, 23:20]


Módulo gsm por dio123
[30 de Novembro de 2016, 13:39]


RAM SO-DIMM 256 MB por Hugu
[29 de Novembro de 2016, 22:52]

Autor Tópico: Problemas no arduino  (Lida 4469 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline AJoao

  • Mini Robot
  • *
  • Mensagens: 126
Problemas no arduino
« em: 18 de Abril de 2011, 20:31 »
Olá. Eu estou com um problema no meu arduino...
O arduino é o BT ATmega328. E não consigo fazer qualquer upload do pc para o arduino.
Esta aqui o print do erro que ele faz.
Se alguem me pudesse ajudar, agradecia...



Cumprimentos

Offline GnGz

  • Mini Robot
  • *
  • Mensagens: 665
Re: Problemas no arduino
« Responder #1 em: 18 de Abril de 2011, 20:40 »
Para te ajudar , responde ás seguintes questões:

  • O Chip com o codigo anterior funciona ?
  • Verificaste a Porta COM ?
  • Verificaste se a board é a Correcta?

Offline FET_Destroyer

  • Mini Robot
  • *
  • Mensagens: 213
    • Fet Destroyer
Re: Problemas no arduino
« Responder #2 em: 18 de Abril de 2011, 20:55 »
Visto noutro site qualquer

Citar
I have the same problem. I have a arduino NG plus and I used it for like 4 months. last week I got this error : 

Binary sketch size: 6378 bytes (of a 14336 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when i used a other computer the problem was gone.

Online senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: Problemas no arduino
« Responder #3 em: 18 de Abril de 2011, 20:57 »
Ou se estão a esquecer de selecionar a placa correcta, ou o Arduino correcto ou coisa parecida.
Ou então, quando aparece a mensagem a dizer o tamanho do sketch carrega no botão de reset.
Avr fanboy

Offline CBX

  • Mini Robot
  • *
  • Mensagens: 1.315
Re: Problemas no arduino
« Responder #4 em: 18 de Abril de 2011, 21:37 »
o Arduino BT não faz reset automático, tens de carregar no botão como o Senso disse...

Online senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: Problemas no arduino
« Responder #5 em: 18 de Abril de 2011, 21:38 »
Se não faz reset automático como é que tem funcionado antes? :coçaracabeça:
Avr fanboy

Offline CBX

  • Mini Robot
  • *
  • Mensagens: 1.315
Re: Problemas no arduino
« Responder #6 em: 18 de Abril de 2011, 21:42 »
ele diz que não consegue fazer qualquer upload...

Online senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: Problemas no arduino
« Responder #7 em: 18 de Abril de 2011, 22:13 »
Então é o reset que está a faltar.
Avr fanboy

Offline AJoao

  • Mini Robot
  • *
  • Mensagens: 126
Re: Problemas no arduino
« Responder #8 em: 19 de Abril de 2011, 14:26 »
Eu já fiz reset, mas ele continua a fazer o mesmo.
Tipo, no inicio, quando o comprei eu consegui comunicar com ele, enviei o blink e meti-lhe o led, para ver se ele funcionava e sim, ele funcionou, então meti-o de lado durante uma semana ou duas e criei um programa que preciso para ele controlar um carro por bluetooth, o programa não dá erros nenhuns, mas agora é ele que não está a receber nada.
Tive um problema com as portas Com, mas resolvi ao comprar uma outra pen bluetooth, porque o pc agora nem o encontrava, ao comprar outra pen ele encontrou logo, só que á hora de fazer o upload ele dá aquele erro.
A board também está bem.
Isso do chip é que não percebi...

Online senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: Problemas no arduino
« Responder #9 em: 19 de Abril de 2011, 14:37 »
Tens alguma coisa ligada ao Arduino?
Isso continua a ser falta de reset, é preciso dar no momento certo.
Avr fanboy

Offline AJoao

  • Mini Robot
  • *
  • Mensagens: 126
Re: Problemas no arduino
« Responder #10 em: 19 de Abril de 2011, 15:26 »
Mas ainda agora eu experimentei.
Fiz o verify, quando terminou fiz o reset, depois cliclei em upload e ele fez o mesmo erro, vou mandar uma foto de como está ligado neste momento.


Online senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: Problemas no arduino
« Responder #11 em: 19 de Abril de 2011, 15:32 »
3v?
Eu não sei que alimentação esse Arduino tem normalmente, mas ou é 5v ou é pelo menos 3.3v....
E como é que fazes verify e só depois o upload? É feito tudo junto.
Mal o IDE dá o tamanho do sketch tens de carregar no reset, mas cá para mim é falta de alimentação.
Avr fanboy

Offline AJoao

  • Mini Robot
  • *
  • Mensagens: 126
Re: Problemas no arduino
« Responder #12 em: 19 de Abril de 2011, 15:40 »
Então meto mais uma pilha destas? É que tenho medo de o queimar, foi muito caro...

Online dvdt

  • Mini Robot
  • *
  • Mensagens: 1.215
  • David_@@@_Teles
Re: Problemas no arduino
« Responder #13 em: 19 de Abril de 2011, 15:40 »
eu ja tive um problema parecido mas mandei o para a loja e ele chegou la e nao sei o que e que eles fizeram e disseram que estava a funcionar normalmente
nao sei se ele tinha algum problema e eles o arranjaram e disseram que estava bom apenas para eu pagar os esportes
agora o que eles fizeram nao sei
David Teles

Online dvdt

  • Mini Robot
  • *
  • Mensagens: 1.215
  • David_@@@_Teles
Re: Problemas no arduino
« Responder #14 em: 19 de Abril de 2011, 15:42 »
esse arduino funciona no makimo a 5 volts nunca ultapasses isso
David Teles