collapse

* Links de Robótica

* Posts Recentes

Printer 3D barata por andre_f_carvalho
[Hoje às 14:37]


Procuro resistências 220 Ohm de 1% por brunus
[Ontem às 15:50]


Package de cond 10uF 35V smd? por KammutierSpule
[Ontem às 11:19]


Videos hipnoticos de mecanica industrial por TigPT
[Ontem às 00:07]


FPV Drone Racing? por brunus
[Ontem às 00:00]


Decodificar cabo por Hugu
[01 de Dezembro de 2016, 23:11]


Ajuda para replicar e reparar um Dimmer por brunus
[30 de Novembro de 2016, 23:23]


Adaptar impressora 3D a Drill Maschine por Hugu
[30 de Novembro de 2016, 23:20]


Módulo gsm por dio123
[30 de Novembro de 2016, 13:39]


RAM SO-DIMM 256 MB por Hugu
[29 de Novembro de 2016, 22:52]

Autor Tópico: [Dúvida] Arduino  (Lida 1128 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline diogom8

  • Mini Robot
  • *
  • Mensagens: 4
[Dúvida] Arduino
« em: 23 de Abril de 2011, 01:26 »
Boas!

Sou newbie nestas andanças e precisava aqui de uma ajuda.

O arduino que tenho, foi um que construí num workshop feito na faculdade, chamaram-lhe neecduino podem ver um exemplar neste link: Neecduino Super Mario Theme

Bem, a questão é que quando faço upload dos programas ele dá-me um erro, no entanto alguns acabam por funcionar na mesma outros não.

O erro que obtenho é o seguinte:
avrdude: stk500_paged_load(): (a) protocol error, expect=0x14, resp=0x14
avrdude: stk500_cmd(): programmer is out of sync

Aqui fica uma print:


Se alguém me pudesse dar uma ajuda a solucionar este problema ficava agradecido.

Obrigado desde já!

Cumprimentos,

diogom8

Offline diogom8

  • Mini Robot
  • *
  • Mensagens: 4
Re: [Dúvida] Arduino
« Responder #1 em: 26 de Abril de 2011, 00:05 »
ninguém tem uma dica? ;)

Offline xiserre

  • Mini Robot
  • *
  • Mensagens: 277
Re: [Dúvida] Arduino
« Responder #2 em: 26 de Abril de 2011, 09:21 »
eu ate ajudava.. mas ando as cegas.. nao consigo ver as imagens, e nao encontro nada sobre esse arduino

Offline RLFuse

  • Mini Robot
  • *
  • Mensagens: 52
  • Prática leva à perfeição
    • Codename: Stuart Little
Re: [Dúvida] Arduino
« Responder #3 em: 26 de Abril de 2011, 13:30 »
Mais informações sobre o neecduino: http://neecist.ist.utl.pt/neecduino/
Partindo do principio que tens tudo bem configurado então às vezes acontece esse problema. Comigo resulta desligar e voltar a ligar o cabo usb ou premir o botão reset e tentar de novo.

Offline diogom8

  • Mini Robot
  • *
  • Mensagens: 4
Re: [Dúvida] Arduino
« Responder #4 em: 26 de Abril de 2011, 20:41 »
Obrigado pela ajuda  :)

A mim, não sei se devido a este problema, quando uso programas com while's não consegue fazer upload, tenho que substituir por for's, não sei se será normal...

Offline GnGz

  • Mini Robot
  • *
  • Mensagens: 665
Re: [Dúvida] Arduino
« Responder #5 em: 26 de Abril de 2011, 20:50 »
Estás a usar bem o while? mostra lá o teu programa com o while?

Cumps :D

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 8.988
  • Helpdesk do sitio
Re: [Dúvida] Arduino
« Responder #6 em: 26 de Abril de 2011, 20:53 »
Bem ou mal, não fazer o upload é muito estranho..
Não encontrei documentação nem um esquema no site, mas imagino que o Tiny esteja a correr V-USB para fazer uma ponte USB-Serial da mesma maneira que um FTDI a faz, será um bug no código do Tiny?
Avr fanboy