collapse

* Posts Recentes

Rede de comboios elétricos totalmente autónomos 10 ton em Rust em realtime. por blabla
[18 de Setembro de 2022, 18:44]


NiMH por 18650 por almamater
[18 de Setembro de 2022, 17:21]


How We Get Down to 0.2nm CPUs and GPUs - TechTechPotato por blabla
[18 de Setembro de 2022, 15:38]


Nova secção de Raspberry Pi Bare Metal em C e em Rust e Systems Programming por blabla
[04 de Setembro de 2022, 08:55]


The code for AGI will be simple - John Carmack and Lex Fridman por blabla
[29 de Agosto de 2022, 07:36]


Wavelets: a mathematical microscope por blabla
[28 de Agosto de 2022, 20:50]


Bom livro - Dive Into Systems por blabla
[28 de Agosto de 2022, 12:19]


graus negativos inclinação por josecarlos
[28 de Agosto de 2022, 11:31]


Super obsolescência super programada? por SerraCabo
[06 de Agosto de 2022, 11:36]


Motor de aspirador por dropes
[02 de Agosto de 2022, 22:18]

Autor Tópico: Como resolver "uhmmm" 50Hz Colunas de PC  (Lida 818 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline KammutierSpule

  • Mini Robot
  • *
  • Mensagens: 1.463
Como resolver "uhmmm" 50Hz Colunas de PC
« em: 09 de Novembro de 2021, 08:41 »
Ola forum,
deixo aqui um problema que deve ser muito comum, a ver se alguém ajuda..

Tenho duas colunas/sistemas de som amplificados para ligar ao PC.
Um deles é um modelo "comercial de uma marca conhecida"
Outro foi inventado por mim com módulos amplificador e colunas que aproveitei.

Ambos os casos, e em diferentes sítios da casa, basta ligar as tomadas para fazer o Uhhm 50Hz da rede...

Não importa variar em qualquer caso o potenciômetro, que o Uhhm é sempre da mesma altura de som e não sobe nem desaparece.
também não importa se está ou não ligado ao PC.

As colunas não tem ligação terra.

Porque é que isto está a acontecer?
Como resolver?

Por outro lado, tenho um sistema de som para ligar à TV "dos bons", não tem ligação terra, e não faz barulho 50Hz

Offline jm_araujo

  • Mini Robot
  • *
  • Mensagens: 2.865
  • NERD!
Re: Como resolver "uhmmm" 50Hz Colunas de PC
« Responder #1 em: 09 de Novembro de 2021, 08:51 »
Hum com amplificador sem ligar a nada, com a entrada em shunt (não vá o fio até às placa servir de antena), não sobra muita coisa :).
Ou desenho do amplificador (menos provável com módulos/comercial), ou acho mais provável, filtragem da alimentação.  Experimenta alimentar a pilhas/baterias a ver se o Hum se mantém.
Se desaparece, precisas de meter uns eletroliticos na alimentação/renovar os do comercial.
Se abrires uns amplificadores "bons", ou veres esquemas de DIY, vez que costumam usar bastante capacidade na alimentação.
« Última modificação: 09 de Novembro de 2021, 08:55 por jm_araujo »

Offline KammutierSpule

  • Mini Robot
  • *
  • Mensagens: 1.463
Re: Como resolver "uhmmm" 50Hz Colunas de PC
« Responder #2 em: 22 de Novembro de 2021, 08:48 »
Abri as colunas (sao muito pequenas 5W ? 7W? cada ?)
Sao alimentadas por um transformador AC
Na placa, a fonte de alimentação, tinha um condensador de 3300uF. Tirei esse e meti 2 novos de 2200uF
Inicialmente tinha um ripple de 180mV e baixou para 140mV.

Curioso que se ouvem mais os 50Hz num dos lados da coluna do que no outro, por isso, o problema pode estar em outro condensador...

Offline dropes

  • Mini Robot
  • *
  • Mensagens: 2.105
Re: Como resolver "uhmmm" 50Hz Colunas de PC
« Responder #3 em: 22 de Novembro de 2021, 14:12 »
Há realmente amplificadores sensíveis á alimentação.

Ao se alimentar a CA, o ruido nunca chega a 0; boa filtragem, ferrites, aumenta-se o ganho do pré, blindagens, etc...

Diferenças entre massas, ou alimentação mal distribuída pode causar este ruido incomodo dos 50Hz, basta um pequeno condensador no andar do pre-amp estar com fugas, para isso acontecer.

Imperativo existir um IC dedicado há alimentação, no que se destina a audio.