collapse

* Posts Recentes

Três pequenas palestras fantásticas de Rust na RustConf 2021 por blabla
[Hoje às 08:44]


Meu novo robô por josecarlos
[13 de Setembro de 2021, 21:58]


localizador carro. por dropes
[13 de Setembro de 2021, 21:00]


Fonte para Circuito - Qual escolher? por almamater
[12 de Setembro de 2021, 00:07]


Limpeza por ultra-sons por KammutierSpule
[10 de Setembro de 2021, 09:08]


Programação assíncrona Async e Await em Rust com Tokio. por blabla
[08 de Setembro de 2021, 14:46]


My arm por josecarlos
[06 de Setembro de 2021, 21:56]


Digitalização 3D por senso
[05 de Setembro de 2021, 14:45]


Opinião - Projector LED para Natal por senso
[05 de Setembro de 2021, 14:35]


APN - localizador GPS/GSM por jm_araujo
[31 de Agosto de 2021, 19:19]

Autor Tópico: Glitch em linha I2C  (Lida 2669 vezes)

0 Membros e 2 Visitantes estão a ver este tópico.

Offline SerraCabo

  • Mini Robot
  • *
  • Mensagens: 937
    • Serra Cabo
Glitch em linha I2C
« em: 17 de Fevereiro de 2021, 01:43 »
... só por curiosidade...

Olá.

Estava aqui a vasculhar umas linhas de controlo para tentar perceber quanto a comunicação I2C atravanca o controlador (ATmega 2560 a 16MHz) e deparei com uma coisa curiosa.

Reparem (olhem em baixo) no último bit antes de ACK aparece um glitch na linhas D5. Não aparece sempre (ou não é 'agarrado') mas aparece pelo menos 50% das vezes. Quando aparece, aparece nesse local.



O clock D4 trabalha a 100KHz e a frequência de amostragem está a 8MHz.

Não estou preocupado com isto porque, de uma forma ou outra, o LCD está a funcionar bem.

Outra coisa curiosa: não estava à espera que ele enviasse um byte de cada vez. Estava à espera que houvesse um cabeçalho e despachasse uma molhada de caracteres. Eu suponho que esta comunicação seja unidireccional.

Já agora, este "Logic Analyzer" que trabalha (diz ele) até 24MHz, tem um preço muito acessível e é particularmente útil. O software é o PulseView.

Abraço
SC

Offline SerraCabo

  • Mini Robot
  • *
  • Mensagens: 937
    • Serra Cabo
Re: Glitch em linha I2C
« Responder #1 em: 17 de Fevereiro de 2021, 16:24 »
Já percebi por que aparece o glitch. Dá-se quando o master (controlador) larga a linha de dados (vai passar a receptor). A linha vai para HI (haverá um pull-up qualquer) para que o slave (o LCD), possa colocar a linha a LOW indicando ao master que os dados foram lidos.

Agora, há outra coisa que eu não esperava. Se não houver resposta do slave (desligando, por exemplo a linha de dados), o controlador fica pendurado.