collapse

* Posts Recentes

I Belive por josecarlos
[Ontem às 19:55]


Video - Eskil Steenberg - How I program C - Excelente por blabla
[22 de Novembro de 2023, 19:20]


Meu novo robô por dropes
[20 de Novembro de 2023, 16:37]


Reparação projetor led por elfo106
[16 de Novembro de 2023, 23:05]


Promoções 11-11 por dropes
[12 de Novembro de 2023, 18:17]


Odin - A better alternative to C, C++ and maybe Rust. por blabla
[09 de Novembro de 2023, 18:06]


Balança de precisão com célula de carga de 5 Toneladas por jm_araujo
[09 de Novembro de 2023, 17:17]


Suporte ferro de soldar T12 - Vendida por jm_araujo
[07 de Novembro de 2023, 14:03]


Fotovoltaicas sem gerar para a rede geral por almamater
[01 de Novembro de 2023, 19:13]


freecad por josecarlos
[29 de Outubro de 2023, 19:00]

Autor Tópico: Que sinal é enviado à válvula?  (Lida 2605 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline almamater

  • Mini Robot
  • *
  • Mensagens: 1.902
    • GrcByte - Projectos
Que sinal é enviado à válvula?
« em: 29 de Março de 2023, 09:30 »
Trata-se de um programador\controlador de rega.



O meu tio tem isto num terreno e supostamente deixou de funcionar, poderia estar mal programado e pediu-me para o programar para umas horas específicas. Assim fiz, como não tinha mais nada, apenas o programador, não percbi se estava ou não a funcionar, medi com um multímetro a saída dos fios (verde+preto) mas não há qualquer tensão.. antes ou depois de estar ativado automaticamente.

Entretanto ele arranjou outro igual e pediu-me novamente para o programar, mas desta vez já veio com um conjunto de válvulas\solenoides, mas este também não tem qualquer tensão nos fios depois de estar ativado... pensei que era azar a mais  :P



Liguei então o solenoid aos fios, testei ligar o automático e supostamente está a funcionar, quando inicia o êmbolo fica para dentro e quando pára empurra-o para fora.

Logo, possivelmente o primeiro nem está avariado, o solenoide que está lá na bomba no terreno é que deve estar marado...

Nunca tinha visto isto à frente, usa apenas uma pilha 9V e está a fazer-me confusão a forma como liga\desliga as válvulas\solenoides.. está a escapar-me alguma coisa ou era suposto existir tensão nos fios depois de estar ativado?

O outro até o tinha aberto mas não consegui detetar nada de mais e voltei a fechá-lo.. de qualquer das formas também deve estar Ok.


« Última modificação: 29 de Março de 2023, 09:32 por almamater »

Offline jm_araujo

  • Mini Robot
  • *
  • Mensagens: 2.921
  • NERD!
Re: Que sinal é enviado à válvula?
« Responder #1 em: 29 de Março de 2023, 12:03 »
Não tenho experiência com essas válvulas, mas umas semelhantes (com programador de ligar diretamente à torneira).
Essas eram "latching" , impulso de corrente num sentido para abrir e fica aberta (sem energia), impulso com polaridade inversa para fechar e fica fechada.
« Última modificação: 29 de Março de 2023, 12:05 por jm_araujo »

Offline almamater

  • Mini Robot
  • *
  • Mensagens: 1.902
    • GrcByte - Projectos
Re: Que sinal é enviado à válvula?
« Responder #2 em: 29 de Março de 2023, 13:02 »
Ah ok, possivelmente só com um osciloscópio é que se consegue apanhar o impulso...

Obrigado

Offline jm_araujo

  • Mini Robot
  • *
  • Mensagens: 2.921
  • NERD!
Re: Que sinal é enviado à válvula?
« Responder #3 em: 29 de Março de 2023, 14:34 »
Se for como estamos a supor, dois LED's em anti-paralelo + resistência de 1k chega para ver isso de certeza.

Offline almamater

  • Mini Robot
  • *
  • Mensagens: 1.902
    • GrcByte - Projectos
Re: Que sinal é enviado à válvula?
« Responder #4 em: 29 de Março de 2023, 15:24 »
Ora pois que tb resulta sim senhor  ;D