LusoRobótica - Robótica em Português

Sistemas específicos => Arduino / AVR => Tópico iniciado por: andlig em 09 de Setembro de 2012, 21:47

Título: problema com codigo/placa de arduino
Enviado por: andlig em 09 de Setembro de 2012, 21:47
boa noite venho por este meio pedir uma ajuda sobre o codigo de arduino ou problema de placa do arduino.
   
o codigo que fiz upload com a seguinte montagem que esta em anexo


void setup()
  {
 
  Serial.begin(9600);   
  }

  void loop()
  {
 
  int sensorValue2 = analogRead(A3);
  int sensorValue3 = analogRead(A4);
  int sensorValue4 = analogRead(A5);
 

 
  Serial.print(sensorValue2);
  Serial.print(" ");
  Serial.print(sensorValue3);
  Serial.print(" ");
  Serial.println(sensorValue4);
   
   

  delay(1000);
 
  }
 
 


o problema é o seguinte faco upload do circuito e comeco a seguir pelo serial monitor o valor dos potenciometro quando tenho os potenciometros a zero o lm 35dz esta ok, mas quando comeco a subir o potenciometro que esta na entrada A4 comeca a influenciar o valor do lm35 dz  aqui esta o meu problema como esta aqui mais em baixo nao sei do que sera, alguem me pode ajudar ?

valores do serial monitor
 
    A3      A4       A5      status
     0        0        53       tudo ok
  1023    0        53       tudo ok
     0     1023    40       erro mas nao sei aonde esta o meu erro



muito obrigado

PS: espero que agora esteja mais explicado
Título: Re: problema com codigo/placa de arduino
Enviado por: Pedrock em 10 de Setembro de 2012, 00:23
Tens a certeza que o esquema está igual?
Título: Re: problema com codigo/placa de arduino
Enviado por: andlig em 10 de Setembro de 2012, 22:31
Tens a certeza que o esquema está igual?

desculpe mas enganei-me no esquema ja fiz tanto e ja dei tanta volta que ja nao sei qual é o errado e o certo mas ja revi o esquema é este que vou postar é o correcto

muito obrigado
Título: Re: problema com codigo/placa de arduino
Enviado por: andlig em 10 de Setembro de 2012, 23:04
vou colocar aqui uma imagem talvez alguém me consiga ajuda?

(https://lusorobotica.com/proxy.php?request=http%3A%2F%2Fimg269.imageshack.us%2Fimg269%2F5884%2Fdsc01425as.jpg&hash=7baf3ec042eb00b725d910ae31f87dd4)[/URL]




muito obrigado