LusoRobótica - Robótica em Português

Robótica => Iniciantes => Tópico iniciado por: diogom8 em 23 de Abril de 2011, 01:26

Título: [Dúvida] Arduino
Enviado por: diogom8 em 23 de Abril de 2011, 01:26
Boas!

Sou newbie nestas andanças e precisava aqui de uma ajuda.

O arduino que tenho, foi um que construí num workshop feito na faculdade, chamaram-lhe neecduino podem ver um exemplar neste link: Neecduino Super Mario Theme (http://www.youtube.com/watch?v=wKJ4345JUcI#)

Bem, a questão é que quando faço upload dos programas ele dá-me um erro, no entanto alguns acabam por funcionar na mesma outros não.

O erro que obtenho é o seguinte:
avrdude: stk500_paged_load(): (a) protocol error, expect=0x14, resp=0x14
avrdude: stk500_cmd(): programmer is out of sync

Aqui fica uma print:
(https://lusorobotica.com/proxy.php?request=http%3A%2F%2Fs3.postimage.org%2F676v7h8ib%2Ferro.jpg&hash=6834f7aa02a9074c99e8490fc3b932ea)

Se alguém me pudesse dar uma ajuda a solucionar este problema ficava agradecido.

Obrigado desde já!

Cumprimentos,

diogom8
Título: Re: [Dúvida] Arduino
Enviado por: diogom8 em 26 de Abril de 2011, 00:05
ninguém tem uma dica? ;)
Título: Re: [Dúvida] Arduino
Enviado por: xiserre em 26 de Abril de 2011, 09:21
eu ate ajudava.. mas ando as cegas.. nao consigo ver as imagens, e nao encontro nada sobre esse arduino
Título: Re: [Dúvida] Arduino
Enviado por: RLFuse em 26 de Abril de 2011, 13:30
Mais informações sobre o neecduino: http://neecist.ist.utl.pt/neecduino/ (http://neecist.ist.utl.pt/neecduino/)
Partindo do principio que tens tudo bem configurado então às vezes acontece esse problema. Comigo resulta desligar e voltar a ligar o cabo usb ou premir o botão reset e tentar de novo.
Título: Re: [Dúvida] Arduino
Enviado por: diogom8 em 26 de Abril de 2011, 20:41
Obrigado pela ajuda  :)

A mim, não sei se devido a este problema, quando uso programas com while's não consegue fazer upload, tenho que substituir por for's, não sei se será normal...
Título: Re: [Dúvida] Arduino
Enviado por: GnGz em 26 de Abril de 2011, 20:50
Estás a usar bem o while? mostra lá o teu programa com o while?

Cumps :D
Título: Re: [Dúvida] Arduino
Enviado por: senso em 26 de Abril de 2011, 20:53
Bem ou mal, não fazer o upload é muito estranho..
Não encontrei documentação nem um esquema no site, mas imagino que o Tiny esteja a correr V-USB para fazer uma ponte USB-Serial da mesma maneira que um FTDI a faz, será um bug no código do Tiny?