collapse

* Links de Robótica

* Posts Recentes

Palavras Cruzadas por Hugu
[Hoje às 00:54]


[Projecto] Bomba Airsoft por jm_araujo
[Ontem às 16:54]


Apresentação por Tech_JA
[Ontem às 09:19]


Medir Agua que está no Poço por filjoa
[21 de Setembro de 2017, 20:58]


URGENTE - display de 7 segmentos com backpack por helderjsd
[20 de Setembro de 2017, 12:30]


Preços e fabricantes de pcb por Sérgio_Sena
[19 de Setembro de 2017, 10:20]


Isaac Asimov - I, Robot por senso
[18 de Setembro de 2017, 03:41]


ic SL440 da Plessey? por senso
[16 de Setembro de 2017, 13:11]


Compra Colectiva RS-Amidata por brunus
[15 de Setembro de 2017, 22:31]


Ideias para construir um quadrúpede simples por zordlyon
[15 de Setembro de 2017, 10:18]

Autor Tópico: Ligar dois PIC por SPI  (Lida 3861 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline pedrosal

  • Mini Robot
  • *
  • Mensagens: 7
Ligar dois PIC por SPI
« em: 19 de Outubro de 2009, 22:45 »
Já consegui colocar a comunicação a funcionar mas não fiquei contente com a solução...

A história é a seguinte. Tenho dois PIC do tipo 18 ligados por SPI. O master transmite dados para o slave que contem uma ligação USB para o PC. Na minha arquitectura a ideia é existir um PIC dedicado às questões relacionadas com comunicação e outro ao processamento propriamente dito, daí a ligação.

No master tenho este código:

Código: [Seleccione]
OpenSPI(SPI_FOSC_64, MODE_00, SMPMID);
....

TRISCbits.TRISC2 = 0;
PORTCbits.RC2 = 0;
Delay10TCYx(100);

safePutsSPI(buffer);
Delay10TCYx(100);

PORTCbits.RC2 = 1;
Delay10TCYx(100);

A variável buffer é um string com cerca de 12 chars.

void safePutcSPI(unsigned char c)
{
unsigned char echo;
unsigned char retries;
TRISCbits.TRISC2 = 0;
PORTCbits.RC2 = 0;
Delay10TCYx(1);
while(1)
{
echo=0;
WriteSPI(c);
ReadSPI();
Delay10TCYx(1);
retries = 0;
while(retries < 10)
{
if(DataRdySPI())
{
echo = ReadSPI();
}
else
{
Delay10TCYx(1);
retries++;
}
}

if(echo == c)
{
break;
}
}

PORTCbits.RC2 = 1;
Delay10TCYx(1);
}

O meu RC2 é o Slave Select e está ligado ao SS do slave (naturalmente :) ).

Do lado do Slave tenho:

Ao iniciar:

Código: [Seleccione]
OpenSPI(SLV_SSON, MODE_00, SMPMID);
No loop:

Código: [Seleccione]
if(DataRdySPI())
{
received = getcSPI();
if(received != '\0')
{
buffer[bufferCurrent]=received;

if(bufferCurrent == 11)
{
... send via usb
}
}
else
{
bufferCurrent++;
}
}
            
            
Gostava de saber se alguém conhece alguma solução para eu me ver livre do diabo dos delays e se existem algumas bibliotecas que me possam ajudar. Esta era supostamente a parte fácil do meu projecto :).
            
« Última modificação: 19 de Outubro de 2009, 22:51 por TigPT »

Offline pedrosal

  • Mini Robot
  • *
  • Mensagens: 7
Re: Ligar dois PIC por SPI
« Responder #1 em: 22 de Outubro de 2009, 21:42 »
Posso ver-me livre dos delays assim:

http://www.microchipc.com/Hi-Tech_C_multitask/