collapse

* Posts Recentes

Carregador Solar para Baterias - EBay por almamater
[20 de Setembro de 2019, 21:57]


Trituradora/Destruidora de cartão em tiras por m90mine
[20 de Setembro de 2019, 17:29]


Ajuda na identificação de componente de portatil por m90mine
[20 de Setembro de 2019, 17:19]


Loja online "McMaster" na europa? por senso
[09 de Setembro de 2019, 23:54]


Pasta térmica por thx1011
[04 de Setembro de 2019, 19:35]


Livros opensource de electrónica, transístores e OpAmps. por thx1011
[03 de Setembro de 2019, 19:56]


Que métodos utilizam para limpar as vossas placas após soldadura? por KammutierSpule
[21 de Agosto de 2019, 22:42]


Contas para saber a duração das baterias. por vasco
[21 de Agosto de 2019, 11:10]


Fabricantes de PCB e Assemblage (produção em massa) por Kristey
[21 de Agosto de 2019, 08:51]


Máquina de soldar a fio sem gás LIDL por Hugu
[16 de Agosto de 2019, 18:28]

Autor Tópico: Comando Servo  (Lida 1915 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline tigas_20

  • Mini Robot
  • *
  • Mensagens: 7
Comando Servo
« em: 19 de Fevereiro de 2010, 21:13 »
Boas

Estou a trabalhar para o meu projecto de fim de curso, que deverá ser um carro com um braço robotico.
Mas agora deparei-me com um problema.

Pelo que já li utilizando o comando servo deveria conseguir mover o servo para a direita, centro, e esquerda. Mas não estou a conseguir utilizar este comando.

Eu ponho por exemplo
servo 0,125 - e o servo roda desalmadamente.

e vou alterando o 125 para 75, 100 e acontece a mesma coisa.

Na teoria utilizando um exemplo do manual deveria ocorrer a seguinte situação:

ciclo:
servo 4, 75 ‘ move o servo para uma das posições finais
pause 2000 ‘ espera 2 segundos
servo 4, 150 ‘move o servo para a posição central
pause 2000 ‘ espera 2 segundos
servo 4, 225 ‘move o servo para a posição final oposta
pause 2000
goto ciclo ‘ volta para ciclo


Já aconteceu isto a mais alguém?

Existe alguma solução?

Desde já Muito Obrigado

Cumprimentos
Tiago Lourenço

Offline fre_deri_co

  • Mini Robot
  • *
  • Mensagens: 510
Re: Comando Servo
« Responder #1 em: 05 de Maio de 2010, 14:28 »
Boas Tigas!!!
sei que ja passou mais de 2 meses e meio mas como so ontem conheci este forum por acaso nao deu para eu poder ter ajudado mais cedo... possivelmente ja deves ter solucionado o problema ou entao simplesmente desistido... seja como for deixo aqui a minha sogestão no caso de poder vir a ser util a alguem...
esse problema sim, ja me aconteceu, tendo sido solucionado com a resistencia se 330R que a propria picaxe recomenda ligada em serie com o pin de controlo ou entao o mais vulgar a contecer é o pic passar-se, mudas de pin de saida, obviamente sempre dentro da porta B...

espero que este pequeno tempo que acabo de dedicar ao forum poupe dores de cabeça a alguem  :P
que sempre se partilhe o conhecimento para que sempre se evolua!!!
Frederico Pereira