collapse

* Links de Robótica

* Posts Recentes

Recomendação de um opamp para um DAC r2r por jm_araujo
[Hoje às 10:48]


Feira de electricidade e eletrónica por beirao
[Hoje às 00:32]


RN42 e TP-Link MR3020 por doiga
[Ontem às 19:22]


Ajuda Projecto IR / RF por senso
[Ontem às 13:15]


Ideias para construir um quadrúpede simples por dropes
[21 de Novembro de 2017, 22:43]


Ajuda com TRIAC por senso
[17 de Novembro de 2017, 18:00]


TV LG White Screen por almamater
[15 de Novembro de 2017, 08:37]


Pergunta sobre prototipagem ( Pesquisa ) por luisjustin
[14 de Novembro de 2017, 23:22]


Medir Agua que está no Poço por Njay
[14 de Novembro de 2017, 13:28]


Amplificador audio por beirao
[12 de Novembro de 2017, 23:43]

Autor Tópico: Atmega 162 ICSP Ponyprog200  (Lida 1655 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline jp_

  • Mini Robot
  • *
  • Mensagens: 187
Atmega 162 ICSP Ponyprog200
« em: 14 de Setembro de 2010, 15:38 »
Olá a todos.

Estou a ter problemas em reprogramar um AVR atmega162.

passo a explicar:

Montei este programador: http://www.olimex.com/dev/avr-pg1.html

Fiz a montagem na bredboard com o atmega162 e alguns leds.

Fiz um pequeno programa no ladder pic ( http://www.cq.cx/ladder.pl )

Usei o ponyprog200 para fazer o download e à primeira vista estava tudo bém.

Mas reparei que o tempo que eu tinha programado (1s) não estava correcto.

fui ler o data sheet e verifiquei que este atmega162 vem de urigem com o oscilador interno de 1MHZ e eu tinha feito o programa de piscar o led para um cristal de 8 MHZ.

Como diria o outro "vai daí deitei as unhas ao datasheet" e fiz asneira ... configurei os bits de segurança.

Acontece que nunca mais consegui que o programador detecta-se o micro.

Agora vem a pergunta.

COMO POSSO LIMPAR OS BITS DE SEGURANÇA no atmega162?

já testei com outros AVR e o programador está a funcionar mas este não.

o erro é : Device missing or unknown device (24)

obrigado

jp_

Offline ptrobotics

  • Mini Robot
  • *
  • Mensagens: 133
  • A informática e a robótica estão ao teu alcance!
    • PTRobotics
Re: Atmega 162 ICSP Ponyprog200
« Responder #1 em: 14 de Setembro de 2010, 16:00 »
Honestamente, acho que estás tramado! Salvo erro, só será possivel repor os fusebits se usares um programador paralelo.
Mesmo o programador da Atmel AVRISPV2 http://www.ptrobotics.com/category.php?id_category=59 não irá funcionar por ser série.
No entanto, eu tenho um GALEP 4 http://www.conitec.com/english/galep4.php na PTRobotics para trabalhos e posso repor-te os fusebits sem qualquer custo (obviamente os portes de ida e volta ficam ao teu encargo).
Cumprimentos
Pedro Silva

PTRobotics
www.ptrobotics.com
Apartado 12 2636-901 Rio-de-Mouro Portugal
E-mail, MSN: pedro.silva@ptrobotics.com
Siga-nos no Fórum Blogger Twitter Facebook Linkedin

Offline jp_

  • Mini Robot
  • *
  • Mensagens: 187
Re: Atmega 162 ICSP Ponyprog200
« Responder #2 em: 16 de Setembro de 2010, 10:23 »
Obrigado pela resposta.

Em ultimo recurso vou utilizar a tua oferta.

Mas não conheces nenhum programador por porta paralela home made.

sabes de algum tópico com a descrição dos bits de configuração (para além do datasheet) que esteja explicado de uma forma resumida.

Obrigado,

jp_

Offline eng_mike

  • Mini Robot
  • *
  • Mensagens: 1
Re: Atmega 162 ICSP Ponyprog200
« Responder #3 em: 16 de Setembro de 2010, 11:35 »
 :) Boas,

Para tentares resolver a situação com o programador série, se tiveres possibilidade, injecta no Xtal 1 um clock externo, e testa.

Podes ver a informação detalhada no link:

http://www.edaboard.com/thread131804.html

testa e dá notícias.

Abraço

Mike - PT  :D

Offline jp_

  • Mini Robot
  • *
  • Mensagens: 187
Re: Atmega 162 ICSP Ponyprog200
« Responder #4 em: 16 de Setembro de 2010, 11:47 »

Obrigado Mike-PT
Resolvido  ;D

Usei um gerador de sinais 1Mhz no Xtal 1 e apaguei o micro.

Copiei os bits de configuração de um virgem e ficou a funcionar com o clock interno 1 Mhz.

jp_

Offline ptrobotics

  • Mini Robot
  • *
  • Mensagens: 133
  • A informática e a robótica estão ao teu alcance!
    • PTRobotics
Re: Atmega 162 ICSP Ponyprog200
« Responder #5 em: 16 de Setembro de 2010, 11:49 »
É verdade, também já o fiz uma vez antes de ter o Galep, mas com um gerador de funções.
Penso que com um 4093, um condensador e uma resistência constroi-se um oscilador muito rápidamente. Costumo fazê-lo com os meus miudos como introdução aos circuitos digitais.
Cumprimentos
Pedro Silva

PTRobotics
www.ptrobotics.com
Apartado 12 2636-901 Rio-de-Mouro Portugal
E-mail, MSN: pedro.silva@ptrobotics.com
Siga-nos no Fórum Blogger Twitter Facebook Linkedin