collapse

* Posts Recentes

Problema em Impressora por jm_araujo
[Ontem às 10:59]


Perfi aluminio por senso
[23 de Janeiro de 2020, 14:01]


OPAMPs - configuracoes inversora, nao inversora por jm_araujo
[23 de Janeiro de 2020, 13:42]


Aplicação de IC TP4056 - dissipador por SerraCabo
[22 de Janeiro de 2020, 10:26]


Ajuda atualizar hora NTP Verão/Inverno por vasco
[19 de Janeiro de 2020, 01:31]


Audio - Controlo Volume por SerraCabo
[17 de Janeiro de 2020, 21:20]


Mau condutor por vasco
[14 de Janeiro de 2020, 16:44]


Pequena impressora por jm_araujo
[13 de Janeiro de 2020, 10:34]


Martelo??? por Njay
[13 de Janeiro de 2020, 02:30]


Circuito de proteção para ferro de soldar. por vasco
[11 de Janeiro de 2020, 20:49]

Autor Tópico: Arduino + Nokia  (Lida 1709 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline nunosilvarocha

  • Mini Robot
  • *
  • Mensagens: 337
Arduino + Nokia
« em: 27 de Abril de 2011, 20:23 »
Boa noite,
Hoje decidi tentar controlar o telemóvel por AT commands, mas sem sucesso.
Tentei ligando diretamente ao Arduino, e também com um max232.
Apenas consigo ver alguns caracteres na consola 'lixo' quando ligo o telemóvel, não consigo enviar comandos para os telemóvel
Estou a utilizar um Nokia 6150.
Gostava de sugestões!!

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.637
  • Helpdesk do sitio
Re: Arduino + Nokia
« Responder #1 em: 27 de Abril de 2011, 21:18 »
As tantas já o queimas-te a dar-lhe com sinais rs-232
Avr fanboy

Offline nunosilvarocha

  • Mini Robot
  • *
  • Mensagens: 337
Re: Arduino + Nokia
« Responder #2 em: 27 de Abril de 2011, 22:14 »
nem com max232 nem com divisores de tensão vou lá!!

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.637
  • Helpdesk do sitio
Re: Arduino + Nokia
« Responder #3 em: 27 de Abril de 2011, 22:26 »
Um telemovel nunca funciona com sinais de +/-12v..
Isso o mais certo é ser problema de protocolo, se tiveres um tutorial para seguir ainda bem, se não só com logic analyzer e osciloscópio para ver o que se passa, mas podes já ter queimado a parte do serial, alias, tens a certeza que esse telemovel aceita comandos AT e que estás a mexer nos pinos certos?
Avr fanboy

Offline nunosilvarocha

  • Mini Robot
  • *
  • Mensagens: 337
Re: Arduino + Nokia
« Responder #4 em: 27 de Abril de 2011, 22:34 »
Um telemovel nunca funciona com sinais de +/-12v..
Isso o mais certo é ser problema de protocolo, se tiveres um tutorial para seguir ainda bem, se não só com logic analyzer e osciloscópio para ver o que se passa, mas podes já ter queimado a parte do serial, alias, tens a certeza que esse telemovel aceita comandos AT e que estás a mexer nos pinos certos?
Pela pesquisa que fiz sim, aceita comandos AT e estou a usar os pinos certos!