collapse

* Posts Recentes

Board com dsPIC por beirao
[Ontem às 08:42]


otto robot por josecarlos
[Ontem às 07:28]


Ligar bomba de água 400W a inversor por senso
[18 de Junho de 2018, 19:16]


VS-Solar Challenge 2018 por edeweld
[18 de Junho de 2018, 16:19]


NiCd - Lipo por almamater
[18 de Junho de 2018, 09:51]


Alfândega / Taxas Alfandegárias / Portes por SerraCabo
[17 de Junho de 2018, 17:26]


Vídeos: pontas prova osciloscópio e misturadora de som Tascam por SerraCabo
[17 de Junho de 2018, 15:34]


Bloco óptico (Laser-Sony) por senso
[15 de Junho de 2018, 09:29]


Plataforma Fritzing por LVirtual
[15 de Junho de 2018, 08:38]


Boa compra este osciloscópio? por senso
[14 de Junho de 2018, 10:08]

Autor Tópico: Ajuda, servo.  (Lida 2044 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline amando96

  • Mini Robot
  • *
  • Mensagens: 1.627
  • MAC address? But I have windows...
    • Projects, News, Blog, Tutorials
Ajuda, servo.
« em: 30 de Agosto de 2009, 14:24 »
Bem, preciso do ''controlador'' do motor que está dentro do servo, ouvi dizer que algumas pessoas quando modificam para rotação continua, deixam de usar essa parte, pois, eu quero comprar uns desses circuitos, quem tiver avise!  ;)

Edit Tr3s: "ouvi" com 'h' amando?  ("houvi")
« Última modificação: 19 de Novembro de 2009, 15:07 por amando96 »

Offline amando96

  • Mini Robot
  • *
  • Mensagens: 1.627
  • MAC address? But I have windows...
    • Projects, News, Blog, Tutorials
Re: Procuro os ''restos'' de quando se modifica um servo para gear box.
« Responder #1 em: 19 de Novembro de 2009, 15:02 »
Boas, em vez de abrir um novo tópico, pergunto aqui se não der problemas...

Tinha um servo de rotação contínua a trabalhar bem, e um normal(rotação 180º) partido, por isso soldei o potenciometro no servo de rotação continua(depois de tirar as resistencias que o fazem centrar, e assim o de rotação continua ficou normal, mas a rotação não é de 180º é uns 110º+/-, o que causa isto? estar mal centrado? eu não preciso de muito mais angulo de rotação de qualquer maneira, faz mal usa-lo assim? obrigado
« Última modificação: 19 de Novembro de 2009, 15:13 por amando96 »

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.291
    • Tróniquices
Re: Ajuda, servo.
« Responder #2 em: 19 de Novembro de 2009, 20:05 »
Acho que podem ser várias coisas, como

- teres pifado alguma coisa ao soldar/desoldar

- o teu código não faz os tempos necessários no PWM (se estás a usar a função analogWrite() da biblioteca do Arduino é possivel; usa antes a biblioteca MegaServo, que respeita os tempos certos para controlar servos)

- o valor do potênciómetro não é adequado para o outro servo

- há um bug no teu código de testar o servo que não o deixa fazer 180

- a fonte de alimentação que estás a usar não consegue dar corrente suficiente ao servo em todas as situações (coloca um condensador electrolitico de 10uF a 100uF directamente nos pinos de alimentação do servo)

Boa sorte...

Offline amando96

  • Mini Robot
  • *
  • Mensagens: 1.627
  • MAC address? But I have windows...
    • Projects, News, Blog, Tutorials
Re: Ajuda, servo.
« Responder #3 em: 19 de Novembro de 2009, 20:59 »
obrigado.
sim estou a usar o analog write, é o código ''sweep'' logo no IDE... mas vou usar o mega servo, só para ver. duvido que tenha estragado algo a desoldar, o ferro não esteve lá mais de um segundo de cada vez, o mais certo é o potenciometro não ser adequado, não me lembrei de verificar logo :P