collapse

* Links de Robótica

* Posts Recentes

Organizar fios por Njay
[Hoje às 20:05]


Compras no allPCB por Dave
[Hoje às 14:41]


Pendentes de compras colectivas por Hugu
[Hoje às 00:51]


Preços e fabricantes de pcb por vasco
[Ontem às 23:18]


Palavras Cruzadas por LVirtual
[Ontem às 20:54]


[Projecto] Bomba Airsoft por jm_araujo
[Ontem às 19:01]


Apresentação por Tech_JA
[23 de Setembro de 2017, 09:19]


Medir Agua que está no Poço por filjoa
[21 de Setembro de 2017, 20:58]


URGENTE - display de 7 segmentos com backpack por helderjsd
[20 de Setembro de 2017, 12:30]


Isaac Asimov - I, Robot por senso
[18 de Setembro de 2017, 03:41]

Autor Tópico: "Problem Uploading to board" - Urgente!  (Lida 2535 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline anaes

  • Mini Robot
  • *
  • Mensagens: 26
"Problem Uploading to board" - Urgente!
« em: 18 de Novembro de 2009, 23:16 »
Boa noite,

o meu Arduino Duemilanove, quando tento fazer upload dá-me o seguinte erro:

"Problem Uploading to board".
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

O led na entrada 13 pisca quando se liga o arduino e quando se faz reset.
Já tentei upload de programas simples tipo o blink e nada!

Já pesquisei no google sobre o problema, e apesar de ser um problema bastante vulgar, não consegui soluções.

Cumprimentos

Offline TigPT

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 5.234
    • Tiago Rodrigues
Re: "Problem Uploading to board" - Urgente!
« Responder #1 em: 19 de Novembro de 2009, 00:18 »
Boa noite...

Pela informação descrita, e se o hardware aparentemente não foi danificado, o problema é mesmo do bootloader. Possivelmente algo fez perde-lo.

Aconselho a antes mais nada testar noutro computador para ter a certeza que o problema é do Arduino.

Se se verificar, tentar aplicar esta tecnica:
http://lusorobotica.com/index.php/topic,427.msg2445.html#msg2445

(os anexos são capazes de estar inválidos, estamos a resolver a situação, contudo os links contêm tudo o que é preciso.)

Boa sorte.

Offline metRo_

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 3.726
Re: "Problem Uploading to board" - Urgente!
« Responder #2 em: 19 de Novembro de 2009, 00:59 »
Isso aconteceu-me uma vez por ter o Arduino em cima de uma superfície condutora. Há a possibilidade também de ser por os pinos TX e RX estarem ao ar, experimenta liga-los a GND através de uma resistência por exemplo de 5Kohm.

Offline anaes

  • Mini Robot
  • *
  • Mensagens: 26
Re: "Problem Uploading to board" - Urgente!
« Responder #3 em: 19 de Novembro de 2009, 20:09 »
Obrigado pelas dicas.
Já testei o que o metRo_ aconselhou, mas continua a dar o mesmo erro.
 :-[

TigPT não será muito perigoso flashar o bootloader?!
É que o Arduino é da faculdade e não posso de maneira nenhuma pôr em risco o hardware!  ???

Offline amando96

  • Mini Robot
  • *
  • Mensagens: 1.627
  • MAC address? But I have windows...
    • Projects, News, Blog, Tutorials
Re: "Problem Uploading to board" - Urgente!
« Responder #4 em: 19 de Novembro de 2009, 21:01 »
experimenta carregar no reset quanto a led do pino 13 pisca, já me deu esse erro, mas parou tão repentinamente e inesplicavelmente como apareceu, eu não reinstalei o bootloader...

Offline anaes

  • Mini Robot
  • *
  • Mensagens: 26
Re: "Problem Uploading to board" - Urgente!
« Responder #5 em: 19 de Novembro de 2009, 21:56 »
experimenta carregar no reset quanto a led do pino 13 pisca, já me deu esse erro, mas parou tão repentinamente e inesplicavelmente como apareceu, eu não reinstalei o bootloader...

ok vou tentar ;)

Offline anaes

  • Mini Robot
  • *
  • Mensagens: 26
Re: "Problem Uploading to board" - Urgente!
« Responder #6 em: 19 de Novembro de 2009, 22:08 »
hum n funcionou =| ... era suposto pressionar o reset logo quando se liga o arduino ao usb?! pressionar e largar (1 click rapido)?!


Offline TigPT

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 5.234
    • Tiago Rodrigues
Re: "Problem Uploading to board" - Urgente!
« Responder #7 em: 19 de Novembro de 2009, 22:59 »
Desconfio mesmo do Atmega.

Posso te emprestar um meu para veres se é mesmo deste, e se for só lá vai reflashando....

http://loja.lusorobotica.com/microcontroladores/28-atmega328-with-arduino-bootloader.html

Se quiseres manda-me um pm, envio por correio verde ou podemos nos encontrar na zona de Lisboa.

Offline anaes

  • Mini Robot
  • *
  • Mensagens: 26
Re: "Problem Uploading to board" - Urgente!
« Responder #8 em: 20 de Novembro de 2009, 13:45 »
hum... afinal o problema é dos pcs onde andei a testar o arduino... experimentei num mac de um amigo e fez logo upload!
Tenho de arranjar drivers decentes ... ou então formatar o pc, porque por mais que desinstale e instale novos drivers fica td na mesma.
(Eles já melhoravam a interface de instalação dos drivers para pc)

Obrigado a todos pela ajuda

Offline TigPT

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 5.234
    • Tiago Rodrigues
Re: "Problem Uploading to board" - Urgente!
« Responder #9 em: 20 de Novembro de 2009, 14:19 »
Fica o link para quem precisar de drivers:
http://www.ftdichip.com/FTDrivers.htm

Tentei me controlar para não escrever isto mas não consegui:
"Desde que mudei para MAC que a minha vida passou a ser resolver os meus problemas em vez dos problemas do meu PC!"

Offline amgcgoncalves

  • Mini Robot
  • *
  • Mensagens: 27
Re: "Problem Uploading to board" - Urgente!
« Responder #10 em: 20 de Novembro de 2009, 15:33 »
anaes:

Acho que tenho a solução para alguns dos teus problemas. Dá uma vista de olhos nisto: http://www.ubuntu.com/ e experimenta caso te sintas tentado. De certeza absoluta que muita gente aqui no forum te vai conseguir ajudar com dúvidas mínimas de utilização que possas vir a ter nos primeiros tempos. Nada melhor que um Sistema Operativo com base Unix para trabalhar com micro-electrónica, micro-processadores e programação em C. ;)
The Whys over the Whats, because I'm a theory freak.