collapse

* Posts Recentes

Resmas de Trotinetes por Njay
[Ontem às 17:49]


[Material] Compra de material por papamoscas
[15 de Fevereiro de 2019, 17:05]


Motor com travão por Alfredo Garcia
[13 de Fevereiro de 2019, 22:56]


Porta Arduino Baixando tensao por mauriciosouza100
[08 de Fevereiro de 2019, 13:39]


Fábricas de componentes electrónicos em Portugal? por SerraCabo
[07 de Fevereiro de 2019, 13:54]


Sistema embarcado movido a energia solar por Njay
[06 de Fevereiro de 2019, 15:01]


Tentanto reaver alguns conhecimentos de eletronica por filjoa
[06 de Fevereiro de 2019, 02:58]


bma180 avr por vasco
[03 de Fevereiro de 2019, 21:40]


3D Prusa hephestos da BQ por josecarlos
[30 de Janeiro de 2019, 18:43]


Gerador de lixo radioeléctrico III por SerraCabo
[29 de Janeiro de 2019, 19:40]

Autor Tópico: Bug ao usar Tone()  (Lida 1200 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline DanBar

  • Mini Robot
  • *
  • Mensagens: 685
    • iCAR Lusorobotica Blog
Bug ao usar Tone()
« em: 17 de Março de 2010, 23:45 »
Após várias horas queimadas em frente ao monitor descobri que depois de se usar o comando tone() - para gerar som num buzzer. O pino digital 11 pwm deixa de funcionar.

Isso estava a acontecer que os meus leds RGB deixavam de dar a cor verde que está ligado ao pino 11 (pwm) após dar um tone() no setup.

Vamos a ver como vou resolver isto, visto que no forum arduino.cc não encontro nada.

Para já o meu robot fica mudo  :( :o
Antigo Nick do Forum: iCAR

Projectos iCAR
icar.lusorobotica.com

DB@G
http://www.facebook.com/daniel.barradas

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.602
  • Helpdesk do sitio
Re: Bug ao usar Tone()
« Responder #1 em: 17 de Março de 2010, 23:56 »
Isso é porque usam um timer igual, logo não é possivel usar os dois ao mesmo tempo...
Podes sempre fazer pwm por software
Avr fanboy

Offline microbyte

  • Mini Robot
  • *
  • Mensagens: 1.323
    • http://ricardo-dias.com/
Re: Bug ao usar Tone()
« Responder #2 em: 18 de Março de 2010, 00:37 »
Isso é porque usam um timer igual, logo não é possivel usar os dois ao mesmo tempo...
Podes sempre fazer pwm por software
Sim, já foi discutido no concurso do Desafio Ajudar o Pai Natal.

No meu robot, tive de usar um arduino adicional para por a musica.