collapse

* Posts Recentes

MKR Vidor4000 por josecarlos
[Ontem às 21:05]


PWM com ventoinha por edeweld
[Ontem às 20:42]


Frequência máxima de pwm com controlo de duty cycle de 0 a 100% por Njay
[Ontem às 19:59]


NiCd por NiMH? por jm_araujo
[Ontem às 11:46]


LusoRobótica - Website - Estado actual por TigPT
[19 de Maio de 2018, 22:34]


Concurso Robô Bombeiro 2018 por Tesla
[18 de Maio de 2018, 11:01]


Trafo Amplificador Behrimger ? por jm_araujo
[16 de Maio de 2018, 18:55]


Alfândega / Taxas Alfandegárias / Portes por Njay
[16 de Maio de 2018, 01:26]


Compra Colectiva à Farnell N3-2018 (Maio 2018) por Hugu
[15 de Maio de 2018, 15:34]


Robô BBC micro:bit controlado com gestos no telemóvel Android por Tayeb
[14 de Maio de 2018, 19:41]

Autor Tópico: Bug ao usar Tone()  (Lida 1105 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline DanBar

  • Mini Robot
  • *
  • Mensagens: 685
    • iCAR Lusorobotica Blog
Bug ao usar Tone()
« em: 17 de Março de 2010, 23:45 »
Após várias horas queimadas em frente ao monitor descobri que depois de se usar o comando tone() - para gerar som num buzzer. O pino digital 11 pwm deixa de funcionar.

Isso estava a acontecer que os meus leds RGB deixavam de dar a cor verde que está ligado ao pino 11 (pwm) após dar um tone() no setup.

Vamos a ver como vou resolver isto, visto que no forum arduino.cc não encontro nada.

Para já o meu robot fica mudo  :( :o
Antigo Nick do Forum: iCAR

Projectos iCAR
icar.lusorobotica.com

DB@G
http://www.facebook.com/daniel.barradas

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.502
  • Helpdesk do sitio
Re: Bug ao usar Tone()
« Responder #1 em: 17 de Março de 2010, 23:56 »
Isso é porque usam um timer igual, logo não é possivel usar os dois ao mesmo tempo...
Podes sempre fazer pwm por software
Avr fanboy

Offline microbyte

  • Mini Robot
  • *
  • Mensagens: 1.322
    • http://ricardo-dias.com/
Re: Bug ao usar Tone()
« Responder #2 em: 18 de Março de 2010, 00:37 »
Isso é porque usam um timer igual, logo não é possivel usar os dois ao mesmo tempo...
Podes sempre fazer pwm por software
Sim, já foi discutido no concurso do Desafio Ajudar o Pai Natal.

No meu robot, tive de usar um arduino adicional para por a musica.