collapse

* Links de Robótica

* Posts Recentes

Sensores de distância e temperatura por metRo_
[Hoje às 12:24]


Ligar -VCC em LM741 directamente à massa por Tech_JA
[Hoje às 10:28]


Ligar 2 sensores na mesma porta de 5v por brunus
[26 de Maio de 2017, 01:16]


Dimensionar um 555 em monoestável (Temporizador) por SerraCabo
[26 de Maio de 2017, 00:29]


Muitas placas pequenas numa grande placa pcb - Ter ideia de preços por edeweld
[25 de Maio de 2017, 14:31]


Kit de condensadores que dá jeito ter por edeweld
[25 de Maio de 2017, 13:32]


Compras Aliexpress por dio123
[24 de Maio de 2017, 21:01]


É possivel construir automaticamente a pcb? - isis proteus por edeweld
[24 de Maio de 2017, 10:23]


BOMER (2017) por msr
[22 de Maio de 2017, 17:11]


Apagar E2PROM X28C64P-25 por LVirtual
[22 de Maio de 2017, 16:43]

Autor Tópico: [PROBLEMA] Arduino + Nokia LCD  (Lida 1671 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline AndréD.

  • Mini Robot
  • *
  • Mensagens: 180
    • AndreD Robotics
[PROBLEMA] Arduino + Nokia LCD
« em: 02 de Setembro de 2010, 15:30 »
Boas Pessoal...

Estou com alguns problemas com os codigos disponibilizado aqui no forum, e penso que provavelmente quem fizer download dos mesmos tambem poderá ter os mesmo problemas, por isso decidi criar este topico, para que se possam resolver estes problemas...

Então os codigos a que me refiro sao estes:
but.rar - Topico Menu num LCD Nokia
Nokia.rar - Arduino + LCD Nokia 3310! - PCD8544 / OM6206

No primeiro caso ao verificar o codigo no compilador este mostra o seguinte erro: error: expected identifier before '(' token e aponta para a seguinte linha: #define SDI   4

No segundo caso o erro é o mesmo mas aponta para a linha: #define backLIGHT 13

Será que alguem pode dar uma vista de olhos nos codigos que referi, para em conjunto resolvermos o problema?

Cumps
AndréD.

Offline ricardo-reis

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.300
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #1 em: 02 de Setembro de 2010, 16:24 »
isso em princípio será uma incompactibilidade de 'linguagem' criada pelas alterações feitas ao longo das actualizações do IDE..

experimenta fazer a compilação dos mesmos programas na versão 15 do IDE do arduino, e diz como correu.. em princípio deve dar, dps tens que ir ver quais foram as alterações desd'então, pra resolver o problema..

Offline AndréD.

  • Mini Robot
  • *
  • Mensagens: 180
    • AndreD Robotics
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #2 em: 02 de Setembro de 2010, 17:49 »
Boas...

Depois de uma penosa hora a fazer download das versoes 17, 16 e 15 com a net da tmn tenho a dizer que nao funciona na mesma...Outra coisa a versao 15 e 16 não correm no 7 nem com compatibilidades nem com nada...

Muito Obrigdao pela sugestao amigo Ricardo...

CUmps
AndréD.

Offline metRo_

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 3.725
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #3 em: 02 de Setembro de 2010, 18:19 »
Eu já testei e tenho o mesmo problema e não consigo resolver. :S

Offline Tyran

  • Mini Robot
  • *
  • Mensagens: 293
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #4 em: 02 de Setembro de 2010, 19:26 »
Eu não percebo muito disto de arduino porque programo em C AVR, mas tive a ver e não faltará por aí um include? Os cabeçalhos tem mas por si só normalmente não chega, não sei se o programa arduino trata disso sozinho...

Offline ivitro

  • Mini Robot
  • *
  • Mensagens: 451
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #5 em: 03 de Setembro de 2010, 04:07 »
porque nao tentas noutro compilador?

Offline ricardo-reis

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.300
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #6 em: 03 de Setembro de 2010, 04:10 »
lembrei-me agora de ir comparar datas dos posts com as datas dos lançamentos das versões de ide, e, na altura, devíamos andar todos ainda na versão 12 do ide..

alguém que se chegue à frente pra tentar fazer a actualização ao código?  ::) onde é que anda o pessoal dos  lcds? :P

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.297
  • Helpdesk do sitio
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #7 em: 03 de Setembro de 2010, 13:50 »
Isso baseia-se em alguma biblioteca exterior?
Se usar só a de spi ou i2c nao deve ser dificil dar com o "erro"
Avr fanboy

Offline AndréD.

  • Mini Robot
  • *
  • Mensagens: 180
    • AndreD Robotics
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #8 em: 03 de Setembro de 2010, 20:16 »
BOas...

Ninguem dá uma actualização no codigo???  :'( :'( :'(

Cumps
AndréD.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.297
  • Helpdesk do sitio
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #9 em: 03 de Setembro de 2010, 21:38 »
Daqui a umas horas vou-lhe dar uma olhadela se conseguir.
Avr fanboy

Offline AndréD.

  • Mini Robot
  • *
  • Mensagens: 180
    • AndreD Robotics
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #10 em: 03 de Setembro de 2010, 23:15 »
Boas...

Dava me um jeitao se pudesses fazer isso amigo...

Cumps
AndréD.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.297
  • Helpdesk do sitio
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #11 em: 03 de Setembro de 2010, 23:54 »
Não estou mesmo a ver que erro estranho é este :o
Não estou a perceber como é que os dois sketchs estão ligados.
« Última modificação: 03 de Setembro de 2010, 23:56 por senso »
Avr fanboy

Offline metRo_

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 3.725
Re: [PROBLEMA] Arduino + Nokia LCD
« Responder #12 em: 04 de Setembro de 2010, 02:14 »
eu na altura tenho a certeza que usava o arduino 12, é uma questão de sacar e experimentar. Como já te disse em privado porta este tópico para o fórum oficial pode ser que alguém tenha tido este problema