collapse

* Posts Recentes

Como ver se uma tomada tem a terra ligada? por jm_araujo
[Hoje às 12:25]


Via Verde - Identificador por TigPT
[17 de Fevereiro de 2018, 09:56]


Estação de soldadura da Banggood, será boa compra ? por vasco
[16 de Fevereiro de 2018, 17:47]


Desenho PCBs 80's por senso
[16 de Fevereiro de 2018, 14:35]


Como guardar componentes SMD ? por vasco
[16 de Fevereiro de 2018, 14:34]


e-bike converter piscas para 12v por vasco
[15 de Fevereiro de 2018, 23:51]


Ebay - fornecedor em Espanha por SerraCabo
[15 de Fevereiro de 2018, 01:11]


BostonDynamics - Vai uma mãozinha? por TigPT
[14 de Fevereiro de 2018, 15:58]


Primeiro campeonato mundial de Ski robótico por TigPT
[14 de Fevereiro de 2018, 15:15]


Ajuda com 5A por almamater
[13 de Fevereiro de 2018, 19:38]

Autor Tópico: XBEE API  (Lida 1784 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline paulo frutuoso

  • Mini Robot
  • *
  • Mensagens: 15
XBEE API
« em: 12 de Novembro de 2011, 22:56 »
Boa Noite

Depois de passar horas à procura, recorro à comunidade porque na verdade so me tenho dado bem com isso.Bom, a duvida é a seguinte.

Já fiz vários testes com o xbee em AT mode. No modo API ainda não consegui. Resumidamente o projecto passa por transmitir inputs de operador (através de teclado e lcd) + estados de switch's/sensores de vários locais de uma fábrica, de modo a serem recolhidos numa base de dados mysql. Além disso, pontualmente, preciso que um arduino comunique com outro. Cada local terá então um arduino+Xbee e pontalmente RFID readers.
Ao que apurei não restam dúvidas sobre o modo a utilizar :API em detrimento do AT.

1 - Todos os XBEE em ZIGBEE ROUTER/END DEVICE API à excepção de um ZIGBEE COORDINATOR API.
Os meus XBee são todos da serie 2.São estas function SET que devo utilizar, ou será ZNET 2.5 coordinator API.

3 - Que librarias devo utilizar ? Xbee.h chega ?  Não quero utilizar processing ou java. Onde arranjo exemplos (pde). Por muito que procure não encontro.

Muito Obrigado

Paulo Frutuoso



Offline luisr320

  • Mini Robot
  • *
  • Mensagens: 1
Re: XBEE API
« Responder #1 em: 05 de Dezembro de 2011, 14:47 »
Olá Paulo. Chegou a resolver o seu problema? Conseguiu usar o API?
Cumprimentos,
Luis

Offline paulo frutuoso

  • Mini Robot
  • *
  • Mensagens: 15
Re: XBEE API
« Responder #2 em: 07 de Dezembro de 2011, 17:02 »
Luis

Obrigado pela sua preocupação.
Consegui, era mesmo problema de principiante... Ainda não domino a 100% ...mas lá chagarei.

Abraço
Obrigado

Offline cvicente

  • Mini Robot
  • *
  • Mensagens: 2
Re: XBEE API
« Responder #3 em: 16 de Abril de 2012, 16:27 »
Boas,

Já agora aproveito para dizer que, há uns tempos atrás comecei a desenvolver um bilbioteca em C++ (bastante modesta para já), para o XBee DIGI API.

Embora esteja longe de estar estável e ser ainda defecitária em funcionalidades, pode no mínimo dar-vos jeito para alguma coisa, nem que seja para reaproveitarem código. No máximo, a contribuição e críticas constructivas!   

Fica aqui a o link: http://code.google.com/p/zigbeelib/

Cumps,

Carlos