collapse

* Links de Robótica

* Posts Recentes

LR, passado, presente e futuro por SerraCabo
[Hoje às 15:02]


Compra Colectiva Mouser.com N1-2018 por Hugu
[Ontem às 14:36]


Printer 3D barata por Hugu
[18 de Janeiro de 2018, 21:02]


Que potência contratada têm em vossa casa? por SerraCabo
[18 de Janeiro de 2018, 16:43]


Lojas Portuguesas de Eletrónica por TigPT
[18 de Janeiro de 2018, 11:00]


Portátil não carrega a bateria... por KammutierSpule
[18 de Janeiro de 2018, 10:39]


Arduino - Controlar fita led por mariana.val
[16 de Janeiro de 2018, 23:25]


O Roomba avariou! por TigPT
[15 de Janeiro de 2018, 11:30]


ic SL440 da Plessey? por brunus
[14 de Janeiro de 2018, 22:13]


e-bike converter piscas para 12v por Njay
[14 de Janeiro de 2018, 22:10]

Autor Tópico: Encoders estranhos  (Lida 1170 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.411
  • Helpdesk do sitio
Encoders estranhos
« em: 08 de Maio de 2012, 22:16 »
Boas noites, á perto de um ano comprei uns encoders da Alps na Mouser, agora que ando de volta do software para a fonte, agarrei neles e para meu espanto os encoders não têm na saida o tipico código de Gray, estão sempre a 3.3v, e quando os rodo é que eles lá fazem o código de gray, os encoders em questão são os PEC11-4215K-S0024.
Não sei se é por ter ligado o comum deles á massa e ter pull-ups(no inicio suspeitava dos pull-ups internos do atmega, então adicionei pull-ups de 10k), e se devia ser ao contrário, mas a datasheet tem muito pouca informação, mas do pouco que apanho dela é assim que se monta estes bichos.
Alguem tem ideias de como usar isto?
É que o código para ler os encoders espera ter código de gray e não ter um sinal a idle constante a 3.3v(HIGH).
Avr fanboy

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.181
    • Tróniquices
Re: Encoders estranhos
« Responder #1 em: 13 de Maio de 2012, 05:29 »
Pega num multimetro e mede a resistência entre o comum e ambos os canais. Se em algumas posições a resistência é infinita entre o comum e ambos os canais em simultaneo, então é mesmo assim que funciona e terás sempre 3.3V em repouso (ou GND se ligares a coisa ao contrário, mas depois tens que inverter em sw - ou não, dependendo da li que tiveres a usar).