collapse

* Posts Recentes

Tipos de "fontes de energia" por Njay
[Hoje às 01:53]


HX711 por senso
[17 de Outubro de 2018, 23:36]


LR, passado, presente e futuro por beirao
[17 de Outubro de 2018, 22:54]


PCB de passadeira por beirao
[17 de Outubro de 2018, 22:51]


Proteções gerais de um circuito por KammutierSpule
[17 de Outubro de 2018, 17:33]


Led driver - Chinesices!!! por vasco
[17 de Outubro de 2018, 15:10]


leitura de voltagens com o analogRead(A0) por vasco
[17 de Outubro de 2018, 11:48]


Como calcular bobina por luisjustin
[16 de Outubro de 2018, 18:11]


Substituir um 78xx por um switching regulator ? por vasco
[16 de Outubro de 2018, 13:50]


BostonDynamics - Vai uma mãozinha? por TigPT
[16 de Outubro de 2018, 12:57]

Autor Tópico: Problemas com l293d  (Lida 1058 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline honor750

  • Mini Robot
  • *
  • Mensagens: 2
Problemas com l293d
« em: 01 de Julho de 2012, 17:20 »
Boas pessoal, estou com uns problemas no meu carro segue linha, vou passar a explicar.

Estou a usar 3 sensores cny70 ligados a um lm324, que por sua vez está ligado a um um atmega88, até aqui tenho o circuito a funcionar direito. Para os motores estou a usar um l293d. Quando andava em testes usava uma fonte com 1.2A para alimentar aquilo pino dedicado aos motores, com uns 7V. Agora mudei para 4 pilhas para alimentar o circuito todo 4 AA, só que não consigo ter os motores a trabalhar como quero. Pensei que poderia ser falta de corrente, então experimentei com 6 pilhas e nada, continuou igual. Tenho aqui umas baterias de 3.7V, com 800mAh cada uma, será que as posso usar? Ah estou a usar um regulador de tensão para não ter mais de 5 V no circuito todo.

Não sei que corrente de input máxima ele aguenta.

Cumprimentos

Offline amando96

  • Mini Robot
  • *
  • Mensagens: 1.628
  • MAC address? But I have windows...
    • Projects, News, Blog, Tutorials
Re: Problemas com l293d
« Responder #1 em: 01 de Julho de 2012, 17:47 »
o que acontece? o chip faz reset continuamente?

Eu meto sempre 9v dedicados para o MCU(através de um regulador para 5v) e 4AA para motores, assim sabes que quando os motores arrancam não vão puxar corrente a mais e desligar o MCU.

Offline honor750

  • Mini Robot
  • *
  • Mensagens: 2
Re: Problemas com l293d
« Responder #2 em: 01 de Julho de 2012, 18:14 »
O que me acontecia é que os motores mal andavam, quando alimentava pelas pilhas.  Andavam aos soluços. Agora testei com as baterias e acho que aquilo tem corrente mais e talvez tenha dado cabo do l293d, aqueceu bastante e os motores andam mal alimento o circuito sendo que o código está definido para ficarem parados.