collapse

* Posts Recentes

Protocolo TLS por vasco
[Ontem às 22:16]


Pequenas chapas de Aluminio - Onde comprar? por Tech_JA
[15 de Junho de 2019, 08:30]


Nuestros dominios web hasta las nubes! por JuanAlbeiro321
[15 de Junho de 2019, 08:25]


stepper motor por jm_araujo
[14 de Junho de 2019, 20:42]


Proteção Lipo por Njay
[11 de Junho de 2019, 21:18]


Medidor de indutâncias por SerraCabo
[10 de Junho de 2019, 12:14]


Carro autónomo por zordlyon
[06 de Junho de 2019, 09:43]


Outlet Lidl por jm_araujo
[03 de Junho de 2019, 13:53]


Torradeira por senso
[30 de Maio de 2019, 16:50]


Editor de ficheiros Gerber por fergas
[28 de Maio de 2019, 15:20]

Autor Tópico: transmission e raspberry problema  (Lida 2493 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline r16

  • Mini Robot
  • *
  • Mensagens: 339
transmission e raspberry problema
« em: 25 de Outubro de 2012, 21:33 »
bom não sei se aqui é o melhor sitio para expor um problema meu com o raspberry se nao for, peço ao moderador que transfira o topico.

Pois bem eu tenho um raspberry com o xbmc instado, ontem instalei o transmission para poder descarregar torrents directamente para o meu cartao do raspberry, e consegui usando este tutorial:

http://1000umbrellas.com/2010/10/04/updated-transmission-installationconfiguration-on-ubuntu-server

funciona tudo correctamente.

depois para eu aceder a esses torrents

eu mapeie no meu windows 7 o ip do rasp

assim \\192.168.1.66\pi

onde aparece a pasta que eu crie com os downloads

mas quando depois tento apagar aparece o problema..

diz que nao tenho permissoes para apagar o ficheiro.

Alguem me pode dizer quais os passos que tenho que alterar no tutorial para conseguir depois apagar os downloads?

Offline poliveira1978

  • Mini Robot
  • *
  • Mensagens: 335
Re: transmission e raspberry problema
« Responder #1 em: 25 de Outubro de 2012, 22:33 »
Se a conta do user do windows tiver o mesmo login e pass que uma conta na Rpi com acesso de escrita a essa pasta não deve haver problema

Offline r16

  • Mini Robot
  • *
  • Mensagens: 339
Re: transmission e raspberry problema
« Responder #2 em: 25 de Outubro de 2012, 22:44 »
Se a conta do user do windows tiver o mesmo login e pass que uma conta na Rpi com acesso de escrita a essa pasta não deve haver problema

como faço isso podes me elucidar?

Offline poliveira1978

  • Mini Robot
  • *
  • Mensagens: 335
Re: transmission e raspberry problema
« Responder #3 em: 25 de Outubro de 2012, 23:12 »
vamos supor o seguinte cenário:
Código: [Seleccione]
Raspberry Pi
User: pi
Password: teste123
No Windows crias uma conta com o login pi e pass teste123 e voilá...
(parto do principio que o user pi tem acesso de escrita na pasta onde descarregas os ficheiros)

Offline TigPT

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 5.348
    • Tiago Rodrigues
Re: transmission e raspberry problema
« Responder #4 em: 26 de Outubro de 2012, 12:39 »
Se for só para acesso local, podes apenas mudar a pasta para acesso por todos com:
Código: [Seleccione]
chmod 777

Offline r16

  • Mini Robot
  • *
  • Mensagens: 339
Re: transmission e raspberry problema
« Responder #5 em: 26 de Outubro de 2012, 19:39 »
Se for só para acesso local, podes apenas mudar a pasta para acesso por todos com:
Código: [Seleccione]
chmod 777

resolvi o problema com este comando

chmode 777 -R ~/pasta~

So 777 nao resolveu

Offline metRo_

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 3.751
Re: transmission e raspberry problema
« Responder #6 em: 26 de Outubro de 2012, 19:45 »
Sim, tinhas que indicar a que pasta/ficheiro querias aplicar a alteração de permissões que é feito com o comando
chmod 777 /pasta

No entanto tambem queres que as permissões das pastas e dos ficheiros dentro dessa pasta se alterem e então acrescentas o -R que vem da palavra recursivo. Então com o comando
chmod 777 -R /pasta ele vai andar por dentro da pasta a alterar as permissões a tudo.