collapse

* Links de Robótica

* Posts Recentes

Palavras Cruzadas por Hugu
[Hoje às 00:54]


[Projecto] Bomba Airsoft por jm_araujo
[Ontem às 16:54]


Apresentação por Tech_JA
[Ontem às 09:19]


Medir Agua que está no Poço por filjoa
[21 de Setembro de 2017, 20:58]


URGENTE - display de 7 segmentos com backpack por helderjsd
[20 de Setembro de 2017, 12:30]


Preços e fabricantes de pcb por Sérgio_Sena
[19 de Setembro de 2017, 10:20]


Isaac Asimov - I, Robot por senso
[18 de Setembro de 2017, 03:41]


ic SL440 da Plessey? por senso
[16 de Setembro de 2017, 13:11]


Compra Colectiva RS-Amidata por brunus
[15 de Setembro de 2017, 22:31]


Ideias para construir um quadrúpede simples por zordlyon
[15 de Setembro de 2017, 10:18]

Autor Tópico: Duvida com montagem/controlo de motores DC  (Lida 5634 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Duvida com montagem/controlo de motores DC
« em: 15 de Junho de 2013, 14:15 »
Boas!
Estou com um problema com uma montagem de motores DC usando uma ponte H. Quando uso apenas os pins de um dos lados, estando então a controlar apenas um Motor DC, tudo corre bem. Contudo quando faço a montagem para 2 motores DC nenhum deles roda..

Que estarei a fazer de mal?? :O

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.088
    • Tróniquices
Re: Duvida com montagem/controlo de motores DC
« Responder #1 em: 15 de Junho de 2013, 14:36 »
Estás à espera que o pessoal adivinhe que hardware e que controlo e ligações é que tens?... Se sim, então recomendo-te o Professor Karamba :), caso contrário é melhor descreveres em pormenor o que é que tens...

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #2 em: 15 de Junho de 2013, 15:20 »
Estás à espera que o pessoal adivinhe que hardware e que controlo e ligações é que tens?... Se sim, então recomendo-te o Professor Karamba :), caso contrário é melhor descreveres em pormenor o que é que tens...

ahah, desculpa la. Pensei que houvesse alguma razão muito obvia que me estivesse a escapar. Estou a usar o l293D e um arduino.
Encontrei na net uma imagem em tudo semelhante à minha montagem, espero que dê para perceberes ;)



A diferença é que aí os motores têm sempre a mesma velocidade, e eu ligo a uma saída do arduino com PWM para poder controlar a mesma.
O que acontece é que se tiver apenas um dos lados ligados, tudo funciona bem, mas quando faço as ligações do outro lado deixa de funcionar :/

Offline MMM

  • Mini Robot
  • *
  • Mensagens: 64
Re: Duvida com montagem/controlo de motores DC
« Responder #3 em: 15 de Junho de 2013, 15:45 »
Já experimentaste ver as tensões de controlo?
Segmentation fault (core dumped)

Offline beirao

  • Mini Robot
  • *
  • Mensagens: 1.483
Re: Duvida com montagem/controlo de motores DC
« Responder #4 em: 15 de Junho de 2013, 17:03 »
Estás a alimentar o circuito com uma pilha? ou como estás a fazer?
"O único lugar onde o sucesso vem antes do trabalho, é no dicionário" - Albert Einstein

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.088
    • Tróniquices
Re: Duvida com montagem/controlo de motores DC
« Responder #5 em: 15 de Junho de 2013, 21:08 »
Pois, se tás a tentar alimentar 2 motores com uma pilha de 9V, se calhar não te safas, as pilhas de 9V fornecem muito pouca corrente.

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #6 em: 15 de Junho de 2013, 21:55 »
Nao tou a usar uma pilha (esquici me de mencionar). O arduino está ligado ao PC e uso uma fonte de alimentação regulavel para ter os 9V para os motores.
Mesmo sem ter o segundo motor ligado aos pins correspondentes quando ligo o primeiro motor ao l293d, nada acontece.

Que acham que pode ser?

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Duvida com montagem/controlo de motores DC
« Responder #7 em: 15 de Junho de 2013, 23:31 »
Algo mal ligado..
Avr fanboy

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #8 em: 16 de Junho de 2013, 01:57 »
Algo mal ligado..
ahaha, boa!
A montagem que fiz está igual à da imagem alguns posts acima. Está algo mal ligado nesse? Será possivel que a fonte que estou a usar nao tenha potencia para os dois motores?

Já agora os motores usados são: 2x  100:1 Micro Metal Gearmotor HP

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Duvida com montagem/controlo de motores DC
« Responder #9 em: 16 de Junho de 2013, 02:08 »
Não consigo olhar para rabiscos do fritzing, para que quero eu saber se é um DIP, quero é ver as funções dos pinos, dai achar isso tão inutil, não vou andar á procura da datasheet e seguir linhas ás cores para ver onde é que ligas-te o quê.
Para começar não tens um unico condensador, não entendo a dificuldade em olhar para uma datasheet e implementar o circuito base que lá está demonstrado, e não saber ler um esquema não é desculpa, é por causa de aberrações da natureza como o fritzing que muita gente não sabe olhar para um esquema..
Depois o Vcc1 deve ser alimentado com a mesma voltagem da tua lógica, neste caso 5v.

E se é para usar pwm's, eu prefiro aplicar pwm nos pinos de enable e usar os outros dois como controlo de direção, poupas 2 pinos capazes de fornecer pwm, e se realmente quiseres poupar mais dois pinos, podes usar um par de transistores a negar o sinal de direção, assim só usas um pino de pwm no enable e um pino para mudar a direção de cada motor, perdes é a capacidade de meter os dois pinos de direção a high/low que permite fazer travagem.
Avr fanboy

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #10 em: 16 de Junho de 2013, 13:30 »
Não consigo olhar para rabiscos do fritzing, para que quero eu saber se é um DIP, quero é ver as funções dos pinos, dai achar isso tão inutil, não vou andar á procura da datasheet e seguir linhas ás cores para ver onde é que ligas-te o quê.
Para começar não tens um unico condensador, não entendo a dificuldade em olhar para uma datasheet e implementar o circuito base que lá está demonstrado, e não saber ler um esquema não é desculpa, é por causa de aberrações da natureza como o fritzing que muita gente não sabe olhar para um esquema..
Depois o Vcc1 deve ser alimentado com a mesma voltagem da tua lógica, neste caso 5v.

E se é para usar pwm's, eu prefiro aplicar pwm nos pinos de enable e usar os outros dois como controlo de direção, poupas 2 pinos capazes de fornecer pwm, e se realmente quiseres poupar mais dois pinos, podes usar um par de transistores a negar o sinal de direção, assim só usas um pino de pwm no enable e um pino para mudar a direção de cada motor, perdes é a capacidade de meter os dois pinos de direção a high/low que permite fazer travagem.

Eu vi a datasheet, e na datasheet, todos os esquemas lá presentes não têm condensadores. Para além disso foi com base na datasheet que fiz a minha montagem. Quanto ao fritzing, esta imagem encontrei na net e tinha o esquema igual ao meu, nem sequer sabia qual o nome do programa para criar isto...
Quanto ao circuito: O vcc1 está ligado aos 5V. Os enables são os que estão ligados às portas pwm e os outros dois pins uso para direção.

Já agora onde deveria acrescentar condensadores? E quais?

Já que tas com problemas com o esquema a cima aqui tens o da datasheet. Visto que quero controlar a direcção dos motores uso a montagem do lado esquerdo em ambos os lados, sendo a diferença que no lado direito o enable é no fundo (porta 9) em vez de no topo.



O que poderá estar a impedir de os dois motores funcionarem?

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #11 em: 17 de Junho de 2013, 15:52 »
Já agora: será possivel que a fonte que estou a usar não tenha corrente suficiente para os dois motores? Mas o estranho é que aquilo deixa de funcionar sem ligar o segundo aos pins respectivos, isto é, deixa de funcionar mal ligo os pins de direcçao e de enable.

Alguma ideia do que pode ser?

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.088
    • Tróniquices
Re: Duvida com montagem/controlo de motores DC
« Responder #12 em: 17 de Junho de 2013, 22:33 »
Bota aí o esquema de como tens as coisas ligadas.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Duvida com montagem/controlo de motores DC
« Responder #13 em: 17 de Junho de 2013, 23:02 »
Engraçado é que tens os pinos de enable ligados aos 5v, não estão ligados a nenhum pino, os unicos pinos que estão ligados ao micro são os da direcção..
Avr fanboy

Offline nvoltex

  • Mini Robot
  • *
  • Mensagens: 211
Re: Duvida com montagem/controlo de motores DC
« Responder #14 em: 18 de Junho de 2013, 01:23 »
Engraçado é que tens os pinos de enable ligados aos 5v, não estão ligados a nenhum pino, os unicos pinos que estão ligados ao micro são os da direcção..

Afinal sempre olhaste para a outra imagem... Eu disse que aquela foi uma imagem que encontrei na net que retratava mais ao menos o meu esquema. Na realidade tanto faz os enables tarem ligados a pwm ou aos 5V, pois o problema está em o motor ligado do lado direito não funcionar. Para além disso, apenas para testar, até  ligar os enables aos 5V mas o problema continuou.

A montagem é portanto semelhante à seguinte:


Quanto aos condensadores, gostava que me pudessem ajudar a saber onde colocar e quais. Estes deste circuito foi quem criou a imagem que colocou, eu só estou a usar esta imagem porque retrata o que estou a fazer à excepção dos condensadores ;)

É estranho porque ainda hoje voltei a fazer a montagem e apenas o motor montado do lado esquerdo do l293d funciona :/