collapse

* Posts Recentes

Onde comprar kit de revelação de PCB's por luiscosta
[Hoje às 11:07]


Boa compra este osciloscópio? por jm_araujo
[Hoje às 07:56]


Frequência máxima de pwm com controlo de duty cycle de 0 a 100% por Njay
[Ontem às 19:02]


Augmented reality AR por josecarlos
[23 de Maio de 2018, 22:14]


MKR Vidor4000 por josecarlos
[23 de Maio de 2018, 18:06]


Robô BBC micro:bit controlado com gestos no telemóvel Android por Tayeb
[22 de Maio de 2018, 13:11]


Programar ATTiny85 sem Arduino por hackeduca
[22 de Maio de 2018, 12:20]


[Técnico de Electrónica] Anuncios para "consoveyo" por KammutierSpule
[22 de Maio de 2018, 09:06]


PWM com ventoinha por jm_araujo
[21 de Maio de 2018, 11:24]


NiCd por NiMH? por jm_araujo
[20 de Maio de 2018, 11:46]

Autor Tópico: Mosfet N-chanel não desliga?  (Lida 2155 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline LuísR.A.

  • Mini Robot
  • *
  • Mensagens: 1.223
    • Clube de Robotica
Mosfet N-chanel não desliga?
« em: 19 de Junho de 2013, 21:48 »
No outro dia queria fazer um interruptor de energia com um senso de mercurio. Fiz com um mosfet N chanel em vez de um transistor porque não me apetecia procurar por um com a corrente necessária.

A ligar tudo bem. O sensor ligava o mosfet e tudo funcionava.
Mas depois não desligava e as vezes até estava num ciclo de ligar e desligar. Isto tudo com o sensor a 0 (com o mercurio fora dos arames)

Alguem pode explicar? Mudei para um transistor para resolver e deu logo
Tiva MCU é que é.

Tutoriais Tiva+codigos exemplo:
https://sites.google.com/site/luiselectronicprojects/

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.283
    • Tróniquices
Re: Mosfet N-chanel não desliga?
« Responder #1 em: 19 de Junho de 2013, 23:17 »
Eu até sou capaz de saber o que é, mas como só disseste "sensor de mercúrio" e não apresentaste um esquema do circuito nem nada, nas verdade não sei do que estás a falar :p. Pergunta ao professor Karamba :)

Offline LuísR.A.

  • Mini Robot
  • *
  • Mensagens: 1.223
    • Clube de Robotica
Re: Mosfet N-chanel não desliga?
« Responder #2 em: 19 de Junho de 2013, 23:51 »
Peço desculpa  :P

é apenas um sensor ON/OFF. o mercurio liga 2 arames quando está numa certa posição.
Quando há essa ligação deixa passar corrente para o gate. apenas isso.
Saida do mosfet no ground

Espero que se veja. Foi no fritzing. O led simula a carga. não era so isso
« Última modificação: 20 de Junho de 2013, 00:04 por LuísR.A. »
Tiva MCU é que é.

Tutoriais Tiva+codigos exemplo:
https://sites.google.com/site/luiselectronicprojects/

Offline Njay

  • Mini Robot
  • *
  • Mensagens: 3.283
    • Tróniquices
Re: Mosfet N-chanel não desliga?
« Responder #3 em: 20 de Junho de 2013, 00:05 »
Liga uma resistência com umas 10x valor de R1 (minimo 10K) entre a gate e a source do MOSFET.

Offline LuísR.A.

  • Mini Robot
  • *
  • Mensagens: 1.223
    • Clube de Robotica
Re: Mosfet N-chanel não desliga?
« Responder #4 em: 20 de Junho de 2013, 00:11 »
eu cheguei a meter uma resistencia entre a o gate e o source...que deverá ser o ligado ao ground certo?
pensei que precisa-se de um pull-down. e pensei que tinha de ser muito maior que a do gate
tinha uma resistencia de 100k no gate e meti uma de 1m nesse "pull-down".
Ai é que acho que começou a piscar.
Tiva MCU é que é.

Tutoriais Tiva+codigos exemplo:
https://sites.google.com/site/luiselectronicprojects/

Offline Sérgio_Sena

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.645
    • Electronic Gear for Musicians
Re: Mosfet N-chanel não desliga?
« Responder #5 em: 20 de Junho de 2013, 10:07 »
eu cheguei a meter uma resistencia entre a o gate e o source...que deverá ser o ligado ao ground certo?
pensei que precisa-se de um pull-down. e pensei que tinha de ser muito maior que a do gate
tinha uma resistencia de 100k no gate e meti uma de 1m nesse "pull-down".
Ai é que acho que começou a piscar.


Nao precisas de proteger a corrente do Gate, pq p a tua aplicacao eh completamente insignificante.

Assim sendo, 100R em serie e 100kR pull-down.

Nao encontrei a tua tensao de alimentacao, mas se for um mosfet dos mais pesados, aplica pelo menos 5V na Gate para o mosfet comutar por completo.

Offline LuísR.A.

  • Mini Robot
  • *
  • Mensagens: 1.223
    • Clube de Robotica
Re: Mosfet N-chanel não desliga?
« Responder #6 em: 20 de Junho de 2013, 12:39 »
Era de 40v. Supostamente comuta facilmente a 3.3v. A tensão das pilhas era 6v
Tiva MCU é que é.

Tutoriais Tiva+codigos exemplo:
https://sites.google.com/site/luiselectronicprojects/

Offline Sérgio_Sena

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.645
    • Electronic Gear for Musicians
Re: Mosfet N-chanel não desliga?
« Responder #7 em: 20 de Junho de 2013, 14:45 »
Era de 40v. Supostamente comuta facilmente a 3.3v. A tensão das pilhas era 6v

Cheira-me q nao estavas a dar tensao suficiente na Gate, visto teres apenas 6V de alimentacao, onde o Vds do mosfet vai ser ainda mais pequeno devido ah queda no LED.

Eh natural que tenha funcionado bem no Bipolar, pois este soh precisa de 0.7V na Base, acima do Emissor, para que comece a conduzir.

Experimenta os valores q escrevi acima e diz-nos.

Offline LuísR.A.

  • Mini Robot
  • *
  • Mensagens: 1.223
    • Clube de Robotica
Re: Mosfet N-chanel não desliga?
« Responder #8 em: 20 de Junho de 2013, 15:26 »
é o que dá não saber essas coisas.

aquilo é um exemplo. em vez do led havia uma placa com um micro, regulador de tensão, transistors, leds rgb.

então tavas a dizer que nos mais pesados é pelo menos no gate 5v acima do source?

no mosfet que usei o Gate to Source Threshold Voltage nunca passa 2.3V:
http://www.ti.com/lit/ds/symlink/csd18503kcs.pdf

Mas o problema não era ligar. era desligar
« Última modificação: 20 de Junho de 2013, 16:16 por LuísR.A. »
Tiva MCU é que é.

Tutoriais Tiva+codigos exemplo:
https://sites.google.com/site/luiselectronicprojects/

Offline Sérgio_Sena

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.645
    • Electronic Gear for Musicians
Re: Mosfet N-chanel não desliga?
« Responder #9 em: 21 de Junho de 2013, 10:08 »
então tavas a dizer que nos mais pesados é pelo menos no gate 5v acima do source?

no mosfet que usei o Gate to Source Threshold Voltage nunca passa 2.3V:
http://www.ti.com/lit/ds/symlink/csd18503kcs.pdf

Mas o problema não era ligar. era desligar


Nao deves ter mts problemas com esse mosfet pois eh de Logic Level activated, o q significa q circuitos digitais simples o podem activar sem grandes problemas.

Ja fizeste os testes com as resistencias aconselhadas ?