collapse

* Links de Robótica

* Posts Recentes

Palavras Cruzadas por brunus
[Hoje às 01:13]


[Projecto] Bomba Airsoft por jm_araujo
[23 de Setembro de 2017, 16:54]


Apresentação por Tech_JA
[23 de Setembro de 2017, 09:19]


Medir Agua que está no Poço por filjoa
[21 de Setembro de 2017, 20:58]


URGENTE - display de 7 segmentos com backpack por helderjsd
[20 de Setembro de 2017, 12:30]


Preços e fabricantes de pcb por Sérgio_Sena
[19 de Setembro de 2017, 10:20]


Isaac Asimov - I, Robot por senso
[18 de Setembro de 2017, 03:41]


ic SL440 da Plessey? por senso
[16 de Setembro de 2017, 13:11]


Compra Colectiva RS-Amidata por brunus
[15 de Setembro de 2017, 22:31]


Ideias para construir um quadrúpede simples por zordlyon
[15 de Setembro de 2017, 10:18]

Autor Tópico: Arduino Uno não compila.  (Lida 4738 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Arduino Uno não compila.
« em: 12 de Dezembro de 2013, 21:47 »
Boas, sem mais nem menos o meu Uno começou a dar a seguinte mensagem de erro.
avrdude: stk500_getsync(): not in sync: resp=0x00

Estive a ler alguma coisa e cheguei á conclusão que poderia ter queimado o bootloader, mandei vir 1 do ebay, e hoje estive entretido a tentar gravar o bootloader no Unoa atravez de um Mega.
Penso que consegui pelo menos foi a mensagem que apareceu.

O que é certo é que continuo com o mesmo erro e já não sei o que fazer, alguma ideia?

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Arduino Uno não compila.
« Responder #1 em: 12 de Dezembro de 2013, 22:04 »
Tens alguma coisa ligada aos pinos digital 0 e digital 1?
E ao pino do reset?
Avr fanboy

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #2 em: 12 de Dezembro de 2013, 22:06 »
Não tenho nada ligado.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Arduino Uno não compila.
« Responder #3 em: 12 de Dezembro de 2013, 22:10 »
Pode ter sido o .inf(o driver), tenta re-instalar o IDE para ver se fica bom.
Avr fanboy

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #4 em: 12 de Dezembro de 2013, 22:16 »
Continua na mesma não sei o que fazer mais :'(

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Arduino Uno não compila.
« Responder #5 em: 12 de Dezembro de 2013, 22:50 »
O que é que fizeste para isso acontecer?
Qual foi a ultima coisa que fizeste com o Arduino?
Avr fanboy

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #6 em: 12 de Dezembro de 2013, 22:52 »
andava a testar um carrinho de 2 rodas com um sensor ultrasonico, mas como já lá vai uns 3 meses já não me lembro bem.

Quando carrego para compilar o led do arduino não pisca fica sempre ligado.
« Última modificação: 12 de Dezembro de 2013, 22:56 por jony-kid »

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Arduino Uno não compila.
« Responder #7 em: 12 de Dezembro de 2013, 22:58 »
Carrega no botão de reset durante 5 ou 6 segundos, desliga do cabo usb e volta a ligar, isso mete o sketch blinky no atmega automaticamente porque a maneira como foi implementado o interface usb-serial se tiveres o arduino a enviar coisas pela porta serial ele facilmente se confunde e não consegue programar.
Avr fanboy

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #8 em: 12 de Dezembro de 2013, 23:20 »
Carrega no botão de reset durante 5 ou 6 segundos, desliga do cabo usb e volta a ligar, isso mete o sketch blinky no atmega automaticamente porque a maneira como foi implementado o interface usb-serial se tiveres o arduino a enviar coisas pela porta serial ele facilmente se confunde e não consegue programar.

Não entendi bem o procedimento.
Mas já tentei os tais 6seg e retirar o usb mas nada aconteceu

Offline dropes

  • Mini Robot
  • *
  • Mensagens: 1.920
Re: Arduino Uno não compila.
« Responder #9 em: 12 de Dezembro de 2013, 23:34 »
Experimentaste ligar a outra porta USB, de preferência que seja da motherboard e não de placa de expansão?

Quando abres o arduino em tools/serial port, aparece alguma sem ser a com1?

Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #10 em: 13 de Dezembro de 2013, 21:47 »
Ora boas.
Hoje tentei com windows XP em outro computador mas continuo com o mesmo erro, Tentei fazer o que o senso aconselhou mas não resultou tambem.

Tenho um mega 2560, há alguma maneira de usar o mega para testar o uno, isto é usar o mega para injetar codigo no uno?


Offline jony-kid

  • Mini Robot
  • *
  • Mensagens: 54
Re: Arduino Uno não compila.
« Responder #12 em: 13 de Dezembro de 2013, 23:51 »
Já tentei e penso que consegui utilizando este video.
m.youtube.com/watch?v=mq5PhM_Fz9Y&desktop_uri=%2Fwatch%3Fv%3Dmq5PhM_Fz9Y

Mas tudo continua na mesma....

Sent from my Nexus 7 using Tapatalk HD

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.390
  • Helpdesk do sitio
Re: Arduino Uno não compila.
« Responder #13 em: 13 de Dezembro de 2013, 23:51 »
Possivelmente alguma coisa se passou com o atmega8u2, possivelmente o software passou-se.
Avr fanboy

Offline Kristey

  • Mini Robot
  • *
  • Mensagens: 753
Re: Arduino Uno não compila.
« Responder #14 em: 14 de Dezembro de 2013, 00:53 »
Uma vez tive um erro parecido durante uns bons minutos...
Pensei que tambem tinha queimado o AtMega, mas afinal era o cabo USB...
Penso que ja deves ter "visto" essa situação.