collapse

* Links de Robótica

* Posts Recentes

Ajuda com TRIAC por senso
[17 de Novembro de 2017, 18:00]


TV LG White Screen por almamater
[15 de Novembro de 2017, 08:37]


Pergunta sobre prototipagem ( Pesquisa ) por luisjustin
[14 de Novembro de 2017, 23:22]


Medir Agua que está no Poço por Njay
[14 de Novembro de 2017, 13:28]


Amplificador audio por beirao
[12 de Novembro de 2017, 23:43]


Power_OK Enermax por edeweld
[12 de Novembro de 2017, 17:15]


Driver motor por beirao
[11 de Novembro de 2017, 17:40]


Preciso de uma fonte de corrente constante ? por samc
[09 de Novembro de 2017, 14:18]


Pressoestato 0-10V por artur36
[07 de Novembro de 2017, 23:22]


Ideias para construir um quadrúpede simples por Njay
[07 de Novembro de 2017, 18:39]

Autor Tópico: Placa /gogoBoard  (Lida 3249 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline ramizluso

  • Mini Robot
  • *
  • Mensagens: 3
Placa /gogoBoard
« em: 12 de Maio de 2009, 14:49 »
Olá Pessoal
Meu nome é Ramiz e estou fazendo iniciação científica com base na GoGo Board
Para um experimento montei um robo (carrinho ) que segue uma faixa no chão
ele tem com fonte de energia 8 pilhas de 1,5 V, utilizo dois motores cc (aqueles de carrinho de controle remoto de 4 pilhas 1,5V), dois Leds, e dois sensores de luz .
Mas ocorre o seguinte problema , após implementar o programa no GOGO Monitor e grava-lo eu mando executa-lo mas ele não segue a programação corretamente o que pode estar ocorrendo ?
Sei q não é erro de programação pois o programa é muito simples, fiz teste com programas mais simples e o problema persistiu
Quem puder me ajudar ficarei grato!

Até mais!

Offline tr3s

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 811
  • char x=1, y=5; x^=y^=x^=y;
Re:Placa /gogoBoard
« Responder #1 em: 12 de Maio de 2009, 15:02 »
Oi Ramizluso!

Tens de nos fornecer mais informação para te possamos ajudar. O que é que acontece quando dizes que ele "nao segue correctamente a programação"? Mostra-nos o código que fizeste, esquemas do circuito usado, etc.

Abraços
Tr3s
Daniel Gonçalves

Offline ramizluso

  • Mini Robot
  • *
  • Mensagens: 3
Re:Placa /gogoBoard
« Responder #2 em: 13 de Maio de 2009, 14:36 »
Este é o código que implementei no GoGo Monitor em linguagem logo


to robomed
forever[
a, off     #motor da direção
cd, setpower 5 # leds
cd, thisway
cd, on
 b, setpower 4   # motor de tração
 b, on
if sensor4 or sensor1 > 600 # sensores de luz
[   
     if sensor4 > 600
       [
         b, off
         b, wait 20
         a, setpower 7
         a, thatway
         ab, onfor 40
       ]
     if sensor1 > 600
       [
        b, off
        b, wait 20
        a, setpower 7
        a, thisway
        ab, onfor 40
       ]]]
end

E aqui esta o link para o esquema de circuitos da minha placa Gogo Board

http://www.gogoboard.org/cocoon/gogosite/availableboards/gogo30/bin/gogo30_pcb.pdf

Obrigado pela atenção

Offline Fifas

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 2.060
  • El RoboSapiens
Re:Placa /gogoBoard
« Responder #3 em: 13 de Maio de 2009, 15:09 »
eu já fiz uma gogoboard mas nunca a usei :P

anyway...qual é o problema que estás a ter?

Offline ramizluso

  • Mini Robot
  • *
  • Mensagens: 3
Re:Placa /gogoBoard
« Responder #4 em: 13 de Maio de 2009, 16:50 »
Bom a placa não segue a programação corretamente eu acho que o problema não esta na implementação do código

O carrinho deveria fazer o seguinte

suguir uma faixa branca no chão, mas quando um dos sensores detectar um faixa preta no chão ele deve fugir ou seja virar para o lado oposto ao da faixa preta, mas a unica coisa que ele faz é ficar virando da esquerda para a direita
 O que pode ser isto ?

Offline lucastanure

  • Mini Robot
  • *
  • Mensagens: 1
Re:Placa /gogoBoard
« Responder #5 em: 20 de Julho de 2009, 03:52 »
peça suporte ao desenvolvedor suportegogo@gmail.com

Offline Sérgio_Sena

  • Administrator
  • Mini Robot
  • *****
  • Mensagens: 1.642
    • Electronic Gear for Musicians
Re:Placa /gogoBoard
« Responder #6 em: 20 de Julho de 2009, 11:09 »
E um programa simples de acender/pagar/piscar LEDs, funciona ?