collapse

* Posts Recentes

BostonDynamics - Vai uma mãozinha? por josecarlos
[Ontem às 11:57]


Tipos de "fontes de energia" por Njay
[Ontem às 01:53]


HX711 por senso
[17 de Outubro de 2018, 23:36]


LR, passado, presente e futuro por beirao
[17 de Outubro de 2018, 22:54]


PCB de passadeira por beirao
[17 de Outubro de 2018, 22:51]


Proteções gerais de um circuito por KammutierSpule
[17 de Outubro de 2018, 17:33]


Led driver - Chinesices!!! por vasco
[17 de Outubro de 2018, 15:10]


leitura de voltagens com o analogRead(A0) por vasco
[17 de Outubro de 2018, 11:48]


Como calcular bobina por luisjustin
[16 de Outubro de 2018, 18:11]


Substituir um 78xx por um switching regulator ? por vasco
[16 de Outubro de 2018, 13:50]

Autor Tópico: Problema módulo TLC59711+Arduino Mega  (Lida 639 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline Emanuel Lourenço

  • Mini Robot
  • *
  • Mensagens: 14
Problema módulo TLC59711+Arduino Mega
« em: 13 de Julho de 2016, 20:11 »
Boas tardes,

Tenho um módulo TLC59711 PWM LED Drive da adafruit, e não estou a conseguir utiliza-lo.

Se alguém me poder ajudar agradecia.

Estou a utilizar um arduino mega com o seguinte codigo

/////////////
#include "Adafruit_TLC59711.h"
#include <SPI.h>

// How many boards do you have chained?
#define NUM_TLC59711 1

#define data 51
#define clock 52

Adafruit_TLC59711 tlc = Adafruit_TLC59711(NUM_TLC59711, clock, data);
//Adafruit_TLC59711 tlc = Adafruit_TLC59711(NUM_TLC59711);

void setup()
{
pinMode(10, OUTPUT);
tlc.begin();
tlc.write();
}

void loop()
{
tlc.setPWM(0, 65535);
tlc.write();
delay(30);
}

///////

No final da compilação dá um aviso, será esse o problema? Deixo o aviso:
AVISO: Pasta .github espúria na biblioteca «Adafruit TLC59711»


Obrigado