collapse

* Posts Recentes

MKR Vidor4000 por josecarlos
[Hoje às 19:04]


Frequência máxima de pwm com controlo de duty cycle de 0 a 100% por senso
[Hoje às 17:46]


PWM com ventoinha por jm_araujo
[Hoje às 11:24]


NiCd por NiMH? por jm_araujo
[Ontem às 11:46]


LusoRobótica - Website - Estado actual por TigPT
[19 de Maio de 2018, 22:34]


Concurso Robô Bombeiro 2018 por Tesla
[18 de Maio de 2018, 11:01]


Trafo Amplificador Behrimger ? por jm_araujo
[16 de Maio de 2018, 18:55]


Alfândega / Taxas Alfandegárias / Portes por Njay
[16 de Maio de 2018, 01:26]


Compra Colectiva à Farnell N3-2018 (Maio 2018) por Hugu
[15 de Maio de 2018, 15:34]


Robô BBC micro:bit controlado com gestos no telemóvel Android por Tayeb
[14 de Maio de 2018, 19:41]

Autor Tópico: Problema ao flashar bios de portátil  (Lida 1225 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline CBX

  • Mini Robot
  • *
  • Mensagens: 1.315
Problema ao flashar bios de portátil
« em: 15 de Março de 2015, 20:37 »
Boas

Veio-me parar às mãos um portátil toshiba l500 com a bios corrompida, de-soldei a bios da motherboard e liguei-a ao programador, fiz o download da única bios disponível no site da toshiba e ao tentar gravar dá-me um erro, o ficheiro é maior que o tamanho do chip 2150266 bytes vs 2097152 bytes, já alguém fez algo do género, está-me a escapar alguma coisa?

Estou a usar um bus pirate com o flashrom em windows

Offline jm_araujo

  • Mini Robot
  • *
  • Mensagens: 2.308
  • NERD!
Re: Problema ao flashar bios de portátil
« Responder #1 em: 15 de Março de 2015, 20:53 »
O ficheiro não deve ser uma imagem da BIOS, deve ter checksum/encriptação/etc junto.

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.503
  • Helpdesk do sitio
Re: Problema ao flashar bios de portátil
« Responder #2 em: 15 de Março de 2015, 21:26 »
Provavelmente é BIOS e EC BIOS, e se é um ficheiro para programar via windows/na bios quando está a funcionar, esquece que não vai funcionar.
Mas tens a certeza que é BIOS?
É que Toshibas quando ligam o led do power e o laranja do WiFi e não fazem mais nada, é muito raro ser só problema de bios.

Tens de ir para foruns manhosos procurar um dump de uma bios funcional.
Avr fanboy

Offline CBX

  • Mini Robot
  • *
  • Mensagens: 1.315
Re: Problema ao flashar bios de portátil
« Responder #3 em: 15 de Março de 2015, 21:51 »
É da bios pois o pc bloqueou a actualiza-la pelo windows  :-X

Penso que já descobri o problema, as bios phoenix têm um padding não sei bem para quê, removendo o padding deve funcionar...

Em ultimo caso tento encontrar uma motherboard não funcional e tiro-lhe a bios ou compro uma no ebay, mas 25€ por uma eeprom ainda é um bocadinho puxado...

Offline senso

  • Global Moderator
  • Mini Robot
  • *****
  • Mensagens: 9.503
  • Helpdesk do sitio
Re: Problema ao flashar bios de portátil
« Responder #4 em: 15 de Março de 2015, 21:54 »
A minha experiência tem sido só com os L600 para cima, pode ser que tenhas mais sorte que eu.
Avr fanboy