collapse

* Posts Recentes

HX711 por senso
[Ontem às 23:36]


LR, passado, presente e futuro por beirao
[Ontem às 22:54]


PCB de passadeira por beirao
[Ontem às 22:51]


Proteções gerais de um circuito por KammutierSpule
[Ontem às 17:33]


Led driver - Chinesices!!! por vasco
[Ontem às 15:10]


leitura de voltagens com o analogRead(A0) por vasco
[Ontem às 11:48]


Como calcular bobina por luisjustin
[16 de Outubro de 2018, 18:11]


Substituir um 78xx por um switching regulator ? por vasco
[16 de Outubro de 2018, 13:50]


BostonDynamics - Vai uma mãozinha? por TigPT
[16 de Outubro de 2018, 12:57]


Kit Completo Robô Inmoov 299€ por aldricnegrier
[15 de Outubro de 2018, 13:39]

Autor Tópico: problema com codigo/placa de arduino  (Lida 1213 vezes)

0 Membros e 1 Visitante estão a ver este tópico.

Offline andlig

  • Mini Robot
  • *
  • Mensagens: 143
problema com codigo/placa de arduino
« em: 09 de Setembro de 2012, 21:47 »
boa noite venho por este meio pedir uma ajuda sobre o codigo de arduino ou problema de placa do arduino.
   
o codigo que fiz upload com a seguinte montagem que esta em anexo


void setup()
  {
 
  Serial.begin(9600);   
  }

  void loop()
  {
 
  int sensorValue2 = analogRead(A3);
  int sensorValue3 = analogRead(A4);
  int sensorValue4 = analogRead(A5);
 

 
  Serial.print(sensorValue2);
  Serial.print(" ");
  Serial.print(sensorValue3);
  Serial.print(" ");
  Serial.println(sensorValue4);
   
   

  delay(1000);
 
  }
 
 


o problema é o seguinte faco upload do circuito e comeco a seguir pelo serial monitor o valor dos potenciometro quando tenho os potenciometros a zero o lm 35dz esta ok, mas quando comeco a subir o potenciometro que esta na entrada A4 comeca a influenciar o valor do lm35 dz  aqui esta o meu problema como esta aqui mais em baixo nao sei do que sera, alguem me pode ajudar ?

valores do serial monitor
 
    A3      A4       A5      status
     0        0        53       tudo ok
  1023    0        53       tudo ok
     0     1023    40       erro mas nao sei aonde esta o meu erro



muito obrigado

PS: espero que agora esteja mais explicado

Offline Pedrock

  • Mini Robot
  • *
  • Mensagens: 279
Re: problema com codigo/placa de arduino
« Responder #1 em: 10 de Setembro de 2012, 00:23 »
Tens a certeza que o esquema está igual?

Offline andlig

  • Mini Robot
  • *
  • Mensagens: 143
Re: problema com codigo/placa de arduino
« Responder #2 em: 10 de Setembro de 2012, 22:31 »
Tens a certeza que o esquema está igual?

desculpe mas enganei-me no esquema ja fiz tanto e ja dei tanta volta que ja nao sei qual é o errado e o certo mas ja revi o esquema é este que vou postar é o correcto

muito obrigado

Offline andlig

  • Mini Robot
  • *
  • Mensagens: 143
Re: problema com codigo/placa de arduino
« Responder #3 em: 10 de Setembro de 2012, 23:04 »
vou colocar aqui uma imagem talvez alguém me consiga ajuda?

[/URL]




muito obrigado